Vigor 167 with German Provider M-net

M-net forced me to a new contract because they are terminating all ISDN contracts. This proved to create quite a bit of work because it meant upgrading from ADSL to VDSL2, which in turn meant either accepting their supported Fritz!Box or a new Modem to use with my OpenWRT router.

I opted for the latter and ordered a Vigor 167 which supports seemingly all ADSL and VDSL flavors. I could not find any posts of this forum and the M-net forum telling how to set this up. The Vigor did connect on DSL but there was no PPPoE connection.

There are two ways to set this up:

  1. Pass the traffic on VLAN 40 back and forth and let then router handle the VLAN.
  2. Have the Vigor handle the VLAN and keep the router as before, VLAN-less.

I use the first method at home (this one here is for the office) with a Deutsche Telekom 50 Mbps line and it works fine. This is with a Vigor 130. But I could not get this to work in the office. Any working /etc/config/network files are welcome.

The second method requires one to switch the "Customer" VLAN setting off and use the "Service" setting. The default has "Customer" on and at VLAN 7 and "Service" off. (Should work for Deutsche Telekom.)

I'm posting this for people who want to build the same setup I have for an M-net DSL line, and in the hope that somebody can shed some light on the setup that uses VLAN 40 between Vigor and OpenWRT.

Maybe Configuration Issues OpenWRT 19.07.3 and DrayTek Vigor 130 - #4 by slh ff. provides some hints (vigor 130/ t-com), while not exactly what you're working with, I would expect it to work similarly.

Thanks for the tip, but no dice. That's for the Vigor 130/Telekom that works fine for many years (knock on wood) at home. The Vigor 167 has quite different settings, for example no Multi-PVC/VLAN. I tried to emulate what I have on the 130, but could not get it to work.

I'm quite sure the problem lies between M-net and OpenWRT. On OpenWRT I have the problem that I have no experience with DSA. I verified that the PADI packets are sent on VLAN 40, but there was no answer and I have no clue why.