Very slow wifi download speed(1/7 of real speed) on WRT3200ACM

Hi.
My problem is as I mentioned very low wifi download speed. Speed I can reach using stock firmware is about 60mbit/s, with OpenWrt it is only about 8mbit/s. I've tried different settings of radio0 configuration and I didn't solve the problem. These are my settings and they are only working settings.

If I change anything radio0 becomes grey and interface isn't working anymore.
Please give me some suggestions what I can do.

BTW. I've installed Davidc502's build but everything looks exactly the same - wifi is very slow.

I'm puzzled, "ASUS_5G" together with "WRT3200ACM" seem a bit unexpected.

No doubt you'll be asked to post your /etc/config/wireless (without keys or other sensitive data). Using the pre-format button in the editor </> makes code and output readable.

1 Like

Why mixed WPA? 802.11n and above require WPA2. Only old 802.11b devices are incompatible with WPA2.

1 Like

Thank you for response.
Here is my /etc/config/wireless file:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'GB'
        option channel '36'
        option htmode 'VHT40'
        option legacy_rates '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option channel 'auto'
        option legacy_rates '1'
        option country 'GB'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'ASUS'
        option key '********'
        option encryption 'psk2'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option country 'US'
        option legacy_rates '1'
        option hwmode '11a'
        option channel 'auto'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option key '********'
        option ssid 'ASUS_5G'
        option wmm '0'
        option encryption 'psk2'

I've had an Asus RT16N router before for years and it has died recently. Instedad of changing name of network connection in every possible device inlcuding guests devices visiting my home I've changed just name of the network in my new router - i know i'm lazy :grin: I'll change the network names someday probably...

@neheb As you suggested I've changed the mixed WPA to WPA2 only. I had such settings in my very first BT-Home router so I just set my home network the same way from then.

It's not a bad idea to change the SSID. It does no harm and can have slight security and privacy advantages. Let's confuse big data!

2 Likes

so, while wifi driver and openwrt devs are still under development, we will have to wait until future realease reach our hands, i guess we have to get use to those speeds rights? im a wrt3200acm owner, doing some wifi transfer speed test between my pc on lan 1 gigabyte port, to my iphone, soon 2nd pc by wifi will be test.

At my iphone i got this speeds when transferint 2gb ".rar" file:
2.4Ghz ch:3 wifi: 3.6mb/s top.
5.0ghz ch:36 wifi: 8.1mb/s top.

Not that this will solve your issue, but it's highly recommended to use a non-overlapping channels, particularly for 2.4 GHz bad--so that would be channels 1, 6 and 11 (well, unless you live in the middle of nowhere, or you have means to prevent your neighbors from using channel 1 or 6).

1 Like

Change your channel width to 80Mhz for 5Ghz band and place these lines in your /etc/rc.local file:
echo 2 > /proc/irq/49/smp_affinity
echo 2 > /proc/irq/50/smp_affinity