Vdsl help please?

Hey guys if someone can see what I'm missing here and give me some advice that would be great. I moved into a new house which only had FTTN but luckily I had an old tp-link w8970 v1.2 from the adsl days and with a quick google I found out it could be used as a vdsl modem/router.. perfect I thought. So got openwrt on there and found a vdsl firmware bin for my connection and loaded all the settings in, this is where I'm stuck, it is saying dsl is up but for the life of me I cant get internet to my PC's no matter what I do. Can someone see something I'm missing?? P.s if its needed my ISP is aussiebroad. Thanks in advance.

network confg file:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdde:5471:fdf7::/48'

config dsl 'dsl'
	option xfer_mode 'ptm0.10'
	option annex 'b'
	option line_mode 'vdsl'
	option firmware '/lib/firmware/vdsl1.bin'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'ptm0.10'
	option proto 'dhcp'
	option ipv6 'auto'


config device 'wan_dev'
	option name 'dsl0'
	option macaddr 'c0:4a:00:7a:c5:67'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

I think you have to change
config dsl 'dsl'
option xfer_mode 'ptm'

and
config interface 'wan'
option ifname 'dsl0.10'

based on the config of my working vdsl modem/router, and assuming that '10' is the right vlan for you.

Thanks for the reply Mijzelf but still no change, are you able to post your entire config file so i can crosscheck everything?

A quick googletrip turned up this information from your ISP:

Router Settings for FTTN/FTTB:

DSL Mode/Interface Type: VDSL
Internet Connection Type: Dynamic or IPOE or DHCP
No VLAN ID
Obtain IP Address Automatically
Enable SRA (if it’s an option; may be under Advanced Settings)

This means that you should use dsl0 instead of dsl0.10, or ptm0 instead of ptm0.10 (the ".10" suffix would make it use VLAN ID 10). Whether it's "dsl0" or "ptm0" depends on the OpenWrt version used, adapt your default configuration there.

Im running openwrt-18.06, so would i add ptm0 to:

-config dsl 'dsl'
option xfer_mode 'ptm0'

and

-config interface 'wan'
option ifname 'ptm0'

is that correct?

I believe this needs to be xfer_mode 'ptm' and not 'ptm0'. This section deals with packet transferpfe PTM versus asynchronous zransferode ATM and not specific interfaces/VLANs.

Good luck.

As @moeller0 correctly said, it must say

config dsl 'dsl'
   option xfer_mode 'ptm'

and 18.06 is already using dsl0 as the ATM/PTM netdev name, so it must be

config interface 'wan'
   option ifname 'dsl0'

I am guessing you followed an older tutorial for LEDE (17.01) that still used "ptm0", as "dsl0" can also be correctly found in your "wan_dev" device where you didn't change it.

and im finely up and running, Thank you everyone and yes i think it was an older post that i was getting my info from. Thanks again everyone.

Just one last thing guys, has there been any update for the 5ghz wifi range? Or is that still unsupported? Thanks.

As of now, it is unsupported.

A few people are working on support for the Wave 300 chipset responsible for the 5GHz wifi, but from the outset it looks like it is more of a labour of love with uncertain outcome.

Ok thanks for the update Takimata I will keep an eye on it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.