Using QNAP QSW-M2108 as a router for ISP connection

I have a QNAP QSW-M2108-2S switch and I found that it runs some sort of openwrt out of the box. I am wondering if it could be used as a router as well.

The switch has 8 2,5gbit/s RJ45 ports in copper and 2 SFP+ ports at 10GbE. It does have a serial port for the console, that allow to access the LEDE prompt, as well.

Does anyone have already tried to combine switch and router functionality on this machine? Maybe on a different hardware?

In order to try, I think I found the list all ethernet ports in file /usr/var/iss.log:

 xcat3PhyAQR412CAddrInit_QSW2108M() devNum = 0
 port = 0, phyaddr= 0x0 
 port = 4, phyaddr= 0x1 
 port = 8, phyaddr= 0x2 
 port = 12, phyaddr= 0x3 
 port = 16, phyaddr= 0x4 
 port = 20, phyaddr= 0x5 
 port = 24, phyaddr= 0x6 
 port = 25, phyaddr= 0x7 
internalXGPortConfig().....devNum = 0x0 portNum= 0x1a ,
internalXGPortConfig().....devNum = 0x0 portNum= 0x1b ,

Then, I found the pppoe parameters required by my ISP. But here I am at loss: shoud i define a switch device in /etc/config/network, then a vlan, then my wan interface? How do i specify the port?

Thank you very much,

It doesn't run stock openwrt/LEDE, but a version created by the manufacturer, based on openwrt/LEDE.

The device isn't supported ( ), and most switches aren't good for routing.

As evidenced by the ToH, this device is not supported by OpenWrt - what the OEM firmware can- or cannot do, is another topic.

Thank you for your quick reply. I would still wait for other answers in order to know if anyone tried this configuration, or a similar one.

Thank you,

I wouldn't hold my breath ...

I am trying again to confgure one port of this switch for ISP connection. I need some help, so maybe someone here have some free time and will to answer to a few questions.

I understood that this is not something that work for sure, but I would like to try it. I found that this OpenWRT based system includes an aricent software named "Intellinge Switch Solution" that seems to really manage the system. I found its configuration in /etc/iss.config that is a link to /etc/M2108-2S.config. This is one of three different configuration files: M2108-2C.config, M2108-2S.config, and M2108R-2C.config. These seems static configurations than let ISS aware of the hardware. These files are a list of commands like this:

xsmi register write device 0 portgroup 0 interface 0 address 0xa register 0xf000 phydev 31 data 0x20c2

and other commands that seems to describe the LEDs.

Then, disabling the firewall and accessing the ISS web interface, you may configure ports and VLAN and change other settings. These are written to a file in directory /etc/sys_conf, named as iss_NNN.conf, where NNN is a serial number. The file headiss.conf in a simbolic link to the latest iss_NNN.conf. These ISS configuration files are in a not-so-readable format, something like this:

1	.	 2	5


2	.18.1	 4	   7	Slot0/1

Beside the ISS, the usual /etc/config/network file is already setup and any new stanza manually added is taken into account. The default configuration include the interface loopback, the globals, the interface lan (setup as a bridge with a unique interface, eth0). Nothing more.

I would like to add a stanza for pppoe in /etc/config/network, but I don't know how to specify the port, and I don't know if I should remove that port from the lan bridge (that do not specify any ports, just the eth0 ifname).

Thank you for your help,