Using OpenWrt, SSH, and network config

Good Morning,
I was successfully able to load OpenWrt using putty and ssh onto a linksys EA6350. I've been playing around with LUCI a bit but I will admit, this stuff is over my head...... So then I tried playing a little after some reading with ssh cmd lines.....and I keep getting permission denied (using /etc/config/network for example).

I've setup two networks, call them 2.4ghz and 5ghz. Can someone please please please walk me through how to change them both to IP addresses of 10.0.0.x, I want to run a FTP server for the Usb port on the router, and I don't want the 2.4Ghz radio to have any internet access (so it's a local-only network) while the 5ghz radio has both local (namely FTP) access AND internet.

Thank you very very much

I think you need first to break the LAN bridge, then assign the 2 Wifi to their own interfaces and firewall zones.
Under the interface you can assign the IP address you please for each Wifi.
Then with firewall zones you can allow or deny (default) the traffic between zones.

I'm doing all of this via LUCI because I don't know how/can't seem to be allowed to do it via SSH

I guess you are trying to execute something like "/etc/config/network", and that is not going to work, because that is a configuration file, not and executable file. You need to edit that file, for example with "vi /etc/config/network" (or your editor of choice).

ahhh that worked. So how do I get LuCI back on? Because I'm back at the point where LuCi again refuses connection in a browser...

Then I want to go back and try to figure out how to setup my two networks....

If you are running OpenWrt 19.07 snapshot (which includes LuCI) on a EA6350v3, and SSH is working but you have lost LuCI for some unknown reason, the easiest way to resolve the issue, is perhaps to perform a simple reset.

While router is up and running (SSH, wifi, etc)
Press and hold in the Reset button in for exactly 10 seconds.
Wait a minute or two after releasing the button, and all openwrt settings will have returned to defaults. Log in using LuCI if you have 19.07-snapshot, otherwise, you will have to download and install the package.

I reset as you said, ran *opkg update followed by opkg install luci and the third try doing this finally got LuCi back!

Thank you.

Now on a side note: would you be able to walk me through how to setup my network either via ssh or Luci?

I'd like two networks- I can name them and such but I can't figure out this part:

  1. How to setup the 2.4GHz so it doesn't get internet access (local only)
  2. How to setup the 5GHz so it does get internet and local access.
  3. How to setup a FTP server that both 2.4GHz and 5GHz have access to (hooking up an external HDD full of movies to the USB port).

Thank you again!

@sassriverrat You have opened two threads for the same issue. It is not appropriate and can cause confusion. Decide which one you want to keep open and close the other one.


Discussion goes on in the topic linked by trendy.

1 Like