Using mSATA SSD

Hello. I have an IPQ4019 custom board from AliExpress. It have 2 mini-PCIe ports. One is used by the modem, and I want to use the second onde with a mSATA SSD. I installed it, but it doesn't appears in /dev. Maybe I have to install some packages?


1 Like

Is it msata or mpcie?
https://www.electronicdesign.com/technologies/memory/article/21800840/whats-the-difference-between-mpcie-and-msata

1 Like

and more beyond that might be needed.

1 Like


the SSD is mSATA. I plugged in in the modem port, nothing changed

None of the already supported ipq40xx devices have SATA ports so far, so you may have to adapt the kernel configuration (and work on the DTS):

$ git grep -i sata target/linux/ipq40xx/
target/linux/ipq40xx/config-5.10:# CONFIG_PHY_QCOM_APQ8064_SATA is not set
target/linux/ipq40xx/config-5.10:# CONFIG_PHY_QCOM_IPQ806X_SATA is not set
target/linux/ipq40xx/config-5.15:# CONFIG_PHY_QCOM_APQ8064_SATA is not set
target/linux/ipq40xx/config-5.15:# CONFIG_PHY_QCOM_IPQ806X_SATA is not set
1 Like

Well, if it's a mSATA card, in a mpcie slot...
Read the link provided.

1 Like

So probably it's incompatible with the port

1 Like

@frollic @slh Is there nothing that can be done? Only buy a box and use it via usb or buy a mPCIe SSD

Do a fined tune google of your board or email you seller at ali

1 Like

I do not know if ipq40xx has SATA support (in terms of a physical SATA controller) at all (but I'm not very hopeful, not in the slightest).

1 Like

There are mpcie sata port adapters, like https://www.amazon.com/dp/B00W8XWPIW

Then put the msata drive in a SATA enclosure.

Would still need to solve the power delivery for the drive though.

EDIT: I can see there's a GND, 12v and 5v pin next to the drive in the photo you posted.

1 Like

looks like the SoC doesn't support SATA at all

1 Like

Booooo

Not a happy ending....

1 Like

Yeah, sad Mac...

This looks like a SATA port and also there is a missing chip. Does someone know what it could be? Maybe its a place for a SATA to USB converter or something?


Check if there's a model with a SATA connector on board...