Using device as "Hotspot-Router" (WISP-Mode)?

I'm really new with OpenWrt and installed it on my RAVPOWER RP-WD03 device a few days ago.

Because I use my device mostly when I am in holydays as a "Hotspot-Router" (WISP-Mode), I made a test:
I configured the "br-lan" ethernet to IP
I connected the device to my existing Wifi (SSID "Gemini") in my household as a client. Then I created another Wifi as AccessPoint (SSID "Apollo"). I could configure, that everyone how connects to "Apollo" is routed to the "Gemini" household Wifi with full internet access. And I am able to access the LuCI web interface with every device connected to the device AP "Apollo". All works fine.

But, I can only see the AP "Apollo" as long as the client connection to existing Wifi "Gemini" is established. As soon as I use the device in another environment (e.g. in my office) where it cannot access "Gemini" there is also no more AP "Apollo" visible. And without an AP "Apollo", I have no possibility to connect wireless to the LuCI web interface.

How can I see always an AccessPoint and configure the device via LuCI, no matter if there is a client connection to an existing Hotspot or not?

Sorry, if I described my issue not very accurate.
With the old OEM-Firmware of the RAVPOWER, I could ever connect to the device with my mobile device, start a scan for existing hotspots and finally connect to one ot them...

I've found something in the Wiki:
but I wounder if that's is what I want and if I reach my goal only using the LuCI web inteface?

Kind regards

The documennt you mentioned describes the issue in Step 3. Have you done that?

When the hotspot is not available or it is incorrectly defined in the wireless configuration file, OpenWrt will disable the AP. This means that you can only access your OpenWrt device through its Ethernet port. The following will describe how to get OpnWrt to test for the hotspot availability after boot. If OpenWrt can not connect to the hotspot after 30 seconds, OpenWrt will automatically reconfigure itself to AP Only mode. This will allow wireless access to your OpenWrt device again.

It looks like it's what you want. There is one way to find out!

You can't do it from LuCU alone. If you are on Windows, get WinSCP It will allow you to easily edit the configuration files in place, as well as make a copy of them to you PC before you change them.

See, for example, the travelmate package

Thanks a lot mhegab.

(Due to my limited english) maybe a silly question:

Since my AP+STA mode already works fine (as long as I have a client connection to an existing hotspot) like I described in my inital posting, do I have to apply the whole configuration (step 1- 4) described in the document, or should I only and alone apply step 3?

Sorry, I'm really bad in linux...


If I were you, I would do Step 3 and see if it will solve the issue. I must say, however, that I haven't tried that setup before, and that I am relatively new to OpenWrt; I am only talking about I read in that document.

You could also try the travelmate package that @jeff mentioned. He is a regular user and well experienced with OpenWrt

Many thanks to you both @Hegabo and @jeff
The travelmate package sounds very good as well! So I will give it a try first.

Please start with the latest snapshot version of travelmate (1.4.0), this version has been widely tested and will be included in forthcoming 19.x OpenWrt release. The travelmate support thread is here: Travelmate support thread

1 Like

Thanks a lot for your support.
I could all this packages install successfully:

  • travelmate_1.4.0-1_all-ipk
  • luci-app-travelmate_git-19.061.64392-718fb97-1_all.ipk

I could NOT install "qrencode", none of this was installable:

  • qrencode_4.0.2-1_x86_64.ipk
  • qrencode_4.0.0-1_x86_64.ipk

I got this error message with both packages:

root@OpenWrt:/tmp# opkg install qrencode_4.0.2-1_x86_64.ipk
Unknown package 'qrencode'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for qrencode found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package qrencode

What I'm doing wrong?
Kind regards

That error means that it is the wrong package build for your CPU type. You can see the name ends in x86_64 not mipsel.

Travelmate and luci-app-travelmate are scripts which means the same files can run on any CPU, so they don't have a CPU type listed.

I'm not sure why something like travelmate would require qrencode.

1 Like

In sum you need two packages for qrencode support (for your architecture):

This is optional, the LuCI interface of travelmate shows the qrcode of configured APs.

How do I find / install this two packages for my architecture? (Like I mentioned; I don't know Linux very well... )

Check your routers architecture, e.g. ...

root@adb2go:~# cat /etc/openwrt_release 
DISTRIB_TAINTS='no-all mklibs'

Then open and switch to the relevant 'DISTRIB_ARCH' directory.

Why would you bother with QR code? just try to solve the issue of having the router connected and function as it should. When all in order, you could look into accessories such as QR Code if you want.

You are right.
I thought I would install everything first (and the QR code would be a cool feature for my family members), and then I'll address my problem.

And to be honest; OpenWrt overstrains me massively. Obviously, it does not help much that I have been working in the information industry for many years. I've never been a "networker" - and now I see "interfaces", "wireless" networks, "bridge-possibilites" and "firewalls" in front of me and have no plan how I must configure everything so that I have a working hotspot router again. (My main problem / wish is still to have permanent wireless access to the access point of my device, no matter if it has an established client connection to an existing hotspot or not ...)

The original OEM firmware of the RAVPOWER RP-WD03 made it relatively simple (even for a non-networker like me ;-), but it was so bad and outdated that I was more annoyed than to take advantage of it. That's why I decided to switch to OpenWrt.

Maybe it would be best, I would still delete all interfaces and wireless networks and start from scratch?

If you can help me, I'm grateful if you do not feel like helping a complete beginner, I would understand it too...

Kind regards

If you have already installed Travelmate, then why don't you just try it?

I've tried it many, many times...with no success. Otherwise I wouldn't ask for help here...

1 Like

If you are in doubt that something might have gone wrong and you think it's easier to just start over, it's up to you.

Or you could try Step 3 if you haven't.

I didn't try any of the solutions in my set-up, so I can't get into the specifics.

In the end, I got it all working - with the patient support of @dibdot. A big thank you for the development and support of Travelmate, Dirk!

Solution / What I had to do:

  • I deleted all Intefaces (Network -> Interfaces) except of the "LAN (br-lan)"
  • I deleted all Wireless Networks (Network -> Wireless) except of the "Generic MAC80211 802.11bgn" (which cannot be deleted).
  • I created a new, first Access-Point (AP) (Network -> Wireless -> Add)
  • I added a Travelmate inteface "trm_wwan" with the Travelmate wizard (Services -> Travelmate)
  • I did a network scan (Services -> Travelmate -> Wireless Stations)
  • I choosed two networks ("Uplink SSIDs) with "Add Uplink" (Services -> Travelmate -> Wireless Stations)

That's all. From this point on my device was working like expected. Travelmate activates / deactivates automatically the available Client Networks (Network -> Wireless) as needed - no manual intervention necessary. Since I had troubles getting the web authentication login site from a specific hotspot (DNS resolution failed), I had additionally to do the following:

  • Disable "Rebind protection" (Network -> DHCP and DNS)
    or, alternatively
  • Add the domain name of the failing web auth login site to the "Domain whitelist" (Network -> DHCP and DNS).

Now, I can wireless access the Webinteface (LuCI) over my configured Access-Point, even my device is not connected to any hotspot. :slight_smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.