Use wrt router as wifi adapter

I have tp-link ac1750 c7 v5

How do i find my main routers ip address? (My parents have a big server room with lots of electronics i don't know which router or modem or server would be the house network i connect to, nor if the label listed on the bottom of the device with ip address woudl still be accurate. )

When reading wifi adapter, I suppose you want to use client mode.

So would i be using client mode or would i be doing the dumb ap thing that jeff listed, i read it but its kinda confusing to be honest.

If you want to connect to an existing Wi-Fi network, then you are looking for the client mode.

How would i set up client mode. Is that under the network tab on openwrt router?
Edit: Do you think one of you could hop into discord and walk me through what i need to do, i found this: but i really don't know how to do this. My discord is: Parker#7768

If your gateway router/ AP allows this, would be the solution - except for not setting up additional repeater AP interfaces and just using the wired ports.

I went to interfaces lan and changed the ipv4 address static from to and saved bc i was following this tutorial: then went to the network wireless section and clicked scann on my routers card and found my main routers wifi then clicked on it and then entered the passowrd and somewhere in that tutorial im not sure where exactly i was but it just disconnected and now i can't find my router. i connected the router with ethernet cord to pc but i can't fidn the wrt web interface online with either ip: or its like goone? i pinged both of them and i get no response? when i type in ipconfig /all it shows the routers default gateway as but i can't connect and when i try to ping it it doesnt' respond...

Surely your PC did not receive the new IP and the changes were reversed.

  1. Reset the router to the default settings.
  2. Change the lan IP to, for example. Then press "Save."
  3. Scan the WiFi networks and connect to your network. Press "Save & Apply."
  4. Remove the cable and reconnect it quickly to receive the new IP from the second router.

I can't get into the router or get into the routers website. Like i pressed reset button on the back and then typed in the and other possible ips and get nothing i can't access it and change anything. oh you think i should change my main routers ip address?

Did you install the correct firmware? What file?

i went to and downloaded then renamed it to firmware.bin after this i plugged etherenet cable back into router and went to the firmware and upgrade section of the website 198... and put in the firmware.bin file and then pressed update.

the issue probably occured when i put in a firewall zone setting zone "wan" and put input reject output except forward reject mss clamping yes ect. i was following that tutorial and then when to wifi scan in network wireless and clicked on my network and then typed password and then just poof its gone.

what do you mean by disconecct wrt from everything except pc? i only downloaded a .bin file and put that on the routers firmware. after trying to make the router a wifi adapter following a tutorial it randomly dc'd and now i can't find its web interface or change anythign on it.

even after resetting the router from button i've tried holding it down and waiting and yet i get nothign

ok so i guess after an hour of doing nothing im able to get into the website for my router and change settings. but only if i type in full address for something like : i can't get into the router if i just go and type into browser it can't connect? wierd. anyway can someone explain like step by step how i set it up so i can just plug etherenet cord into it and then use it as a connector to my wifi that comes from a different router? it doesn't need to broadcast the signals

You need to slow down a bit and change many things at the same time, otherwise it will be difficult to find where the problem is.

OpenWrt has dhcl by default. If you haven't turned out off then just disconnect the OpenWrt from everything except your PC. ipconfig /all should show you the router IP as default gateway.

Then you need to decide how do you want to connect the two routers together. If you connect to OpenWrt LAN then both routers' LAN IPs should be on the same subnet. If you connect to WAN (the blue port) then routers' LAN IPs should be on different networks.

1 Like

If you could change the IP in OpenWrt, it was because it was installed correctly.
You don't have to change the IP of the main router. Only the second one.
Do not make changes in the wan zone, which is fine as it comes by default.
It is easier to do than explain.

Disconnect the router from the PC for at least 30 seconds. The re-connect. Check the PC for what IP it has on the ethernet card (ipconfig on the Windows CLI), it should be either 192.168.18.X or 192.168.1.X.

If you want to reset OpenWrt, let it boot up fully then hold down the reset button for more than 5 seconds and release it. All the lights should blink and the router reboot back to default configuration.

I don't use the "Join Network" button. Manually configure a client wifi in network-wireless. Select "wan" as its network. Then go to network-interfaces-wan-physical settings and double check that no Ethernet port is attached; attach the wifi client instead. Make sure "bridge" is NOT checked. This should give you a routed client. Simply, the wan connection is wireless instead of wired. Of course as noted the IP ranges can't overlap so you may have to change the LAN IP.

Just to add a bit to what @mk24 said, if you can go into the main router and set a static ip for the client or you're always going to have trouble getting back in, also, if your physical reset button isn't working try installing kmod-gpio-button-hotplug and see if that gets it working.