Use separate interfaces for each ethernet port

Hi,

I have an Itus Netoworks Shield on v21.02.3. This device has 3 ethernet ports - 1 WAN & 2 LAN that are in the br-lan configuration.

This hardware has a bug in which if both LAN ports are active on boot, they don't come up and give out IP's. However, if only one LAN port is connected on boot it comes up as expected and then the 2nd can be plugged in.

I have already put hours in trying to network restarts, delaying interfaces, etc. but it doesn't help.

So what should work is both ethernet LAN ports still working as a dumb unmanaged switch but just not bridged - both on their own interface.

What is the configuration to have each ethernet port on their own interface and one DHCP and still work as if they are bridged. Is that doable?

Thank you

They can't be on their own interfaces and use the same network... but the real question is this: are they connected to a hardware switch chip?

Please post your /etc/config/network file, and also the output of ubus call system board

Thanks for the info. I did revert back to br-lan, but here is /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth2'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option ipaddr '10.9.8.7'
	option device 'br-lan'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'
	option peerdns '0'
	list dns '##.##.##.##'
	list dns '##.##.##.##'
	option delegate '0'
	option broadcast '1'

and ubus call system board:


root@OpenWrt:/# ubus call system board
{
        "kernel": "5.4.188",
        "hostname": "OpenWrt",
        "system": "ITUS_SHIELD (CN7020p1.2-1000-AAP)",
        "model": "ITUS_SHIELD (CN7020p1.2-1000-AAP)",
        "board_name": "itus,shield-router",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.3",
                "revision": "r16554-1d4dea6d4f",
                "target": "octeon/generic",
                "description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
        }
}

So it appears that these are not connected to a hardware switch, but are, instead, individually routed ports. The only way to have them operate on the same network is using the bridge. However, if the bridge is a problem (due to a bug), you can remove the bridge and put eth1 (or eth2) into your LAN instead of the bridge. This means that the other port will not be active -- you could create a new (different) network for the second port, but without the bridge, they cannot both participate in the same network.

Ok I'll just leave a port unplugged or only have one port in the interface as you mentioned. Thank you @psherman for the quick replies!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.