Use OpenWrt on a NAS with RAID?

My main question is, does it make any sense to use openWRT on a consumer NAS that uses raid? I have an old seagate BlackArmor 220 NAS (https://wikidevi.com/wiki/Seagate_BlackArmor_NAS_220). I use it with stock firmware still, which is pretty bad. This is a 2 spindle disk NAS with raid 1. It has a single ethernet port and that's about it.

	Here a the main things I need
		- Raid 1 (disks mirrored)
		- Network shares with a couple of users (samba)
	Nice to haves
		- Notification on any disk issues
		- Snmp monitoring

There appear to be Debian builds that will run on it, but I am familiar with OpenWRT. I won't need any real router functionality of course, no Wifi, no Firewall etc so seems a bit goofy. Looks like someone at least had some openwrt builds running on it Seagate BlackArmor NAS 220.

Anyway looking to see if others are running NAS-es with RAID and OpenWRT and getting valuable use out of it. Or if should just put debian on it.

Thanks

I have one of those as well. As it's original disks were dead, I had to improvise. I had to build and install the latest uboot then tried the firmware of the other similar kirkwood models. Unfortunately I had no Ethernet connection with any of them.
A guy here helped me and built an image that booted fine and had internet connection, but I was unable to properly install it on my device due to some bug somewhere in the flash code.

I can share all my knowledge up to this point but don't expect much from this box.
If we could get them working we could make neat torrent or backup boxes out of them, but I wouldn't expect any serious performance from them. I would be amazed if they could exceed 20-30MB/s

...but yes lede can do all the things you asked and even more, eg in my homeserver setup I also have a UPS connected and monitored, and a small web server with php and mysql support

1 Like

Thanks pancyber. Mine is running stock FW now and is definitely not fast for R/W over the network so not expecting much from it, but the stock FW is pretty painful. Just having shell access and some capability to monitor logs etc would be great.

Couple of questions. Do you know if it has serial pins? Which image did you get running? Was it one of Robmarko's from here?

https://drive.google.com/drive/folders/1MFm3As_UFoQ7Q4yFAvNbv9Qf_zlAsfnT

Also did you have the raid array running?

Thanks

yes it has serial pins, you need a 3.3v ttl adapter, you can find the pinout from Google - that is nessesary to install lede on it as there is no officially built upgrade package.
all images from robimarko worked but I couldn't install them as you see, so I abandoned the project
building or importing your raid array is a piece if cake, you just need the mdadm package and boom a simple

mdadm --assemble --scan

should be enough

I used openwrt and lede on other nas devices with no problem, eg, on old p4 with 512mb ram it boots in seconds from a 1gb usb stick and works ~90-110 MB/s through samba

I believe that having the entire OS running from flash (instead actually booting from the HDDs is a lifesaver. First it's memory footprint is amazingly small, leaving precious ram for other apps (eg transmission-daemon). Then, in case the array gets corrupted for some reason eg power outage, your system will boot just fine, and let you ssh in it to fix the problems a debian installation will kernel panic or require human interaction, but you will never know it unless you connect your serial cable

This is great. Thank you for the info. I recently built support for an unsupported router so have the serial/usb deal. Good to hear this thing has pins since I suck at soldering. No idea if this will be in the same space, but I ran into boot issues with the router I was working on where rootfs isn't mounted similar to the boot logs you had so maybe I'll get lucky and it will be similar.

I am going to post to your original post too, to see if robimarko has sources he would be up for sharing.

Well, there are pin holes but you have to solder actual pins on them, so yes soldering is required. If it helps I have already done so and I can test the images for you as I have console access

If you can mail me the board I would be glad to solder them for you ( I consider my self an expert on soldering) I live in Greece

And if you cook any good images please don't forget me :wink:

Bummer to hear there aren't pins. This is my "production" NAS at my house, so hopefully I can do something without taking it offline for very long. Thanks for the soldering offer, but I am in the US. Do you think solderless grabber test clips could work?

I am guessing you have seen this, but this seems to be a pretty complete way to get Debian Stretch on it.

The kernel patch mentioned is the DTS for this device and is in the 4.14 kernel now. In theory this will make an openwrt build relatively straight-forward.

One question I have is why the bootloader needs to be upgraded. Do you know? I know the stock one is very old, but I think this would result in a case where you can't return to stock.

So I am going to back it up and then see about hacking an image for it. Fair warning, I am an amatuer at this stuff. I got a router to work, but I am painfully slow at it. I will definitely offer up any images I get working.

p.s. you are right on this thing being slow, I am currently backing up about 1TB to a USB drive will take about 30 hours.

aligator clips or solderles clamps will not work as there is nothing they can hold on but I will be happy to test any images you may cook so you don't have to

I upgraded the uboot because the one that came with the device didn't have any support for ubifs or device tree files and I was trying to directly write a ubifs image on it's flash. I doubt that the original firmware will complain for the newer uboot as it practicaly just loads uimage on ram and kickstarts it

I have tried debian-arm on a similar intel ss2200 with awful results. I couldn't get the disks to spin down and it took a long to boot. Dont even thing about fsck no matter the raid10 configuration and the xfs format

I think i still have the uboot image somewhere so I can spare you an hour or so of cooking. If you are familiar with uboot you can install it in seconds

Ok. I probably won't get to this right away as I have some other projects ahead of this. But a couple questions from your other posts

  1. Sounds like you had an image booting but no ethernet, but not sure which it was. Was it goflexhome? Which openwrt version? and with this image you just changed

GOFLEXHOME_UBIFS_OPTS:="-m 512 -e 15872 -c 4096" ?

  1. robimarko's initramfs will boot (probably from memory)?
  2. The other robimarko images (factory, sysupgrade) will not boot and will panic on rootfs mount correct?