Use OpenWrt as WiFi client (seems the driver isn't loaded correctly, see last update)

I am using a device that only has WiFi (so it doesn't have any ethernet ports) and I would like to configure OpenWrt so that it can act as a "normal" WiFi client for my existing home WiFi network.

I know this may not be the standard use case for OpenWrt, but the device (a Kickstarter project) is delivered with a specific OpenWrt installation and so I'm trying to configure that for my use case.

The default config creates a bridge and makes the device act as an AP. In addition you can then enable an 'apcli0' device so that the device itself can connect to the internet using your existing WiFi network.

Now I would like to change the configuration so I can omit the AP part and only make the device connect and act as a client to my existing WiFi network. From what I understand I will always need to create a separate LAN configured with a separate subnet, is that correct? It would be nice if it could be configured without that, but if not that's acceptable. As long as I can prevent it from acting as an AP.

The existing (default) configs looks like this:

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd78:1a07:d46d::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option macaddr '9c:65:f9:1d:c6:2b'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.100.1'
        option ipv6 '0'

config interface 'wan'
        option force_link '1'
        option proto 'dhcp'
        option ifname 'apcli0'
        option macaddr '9E:65:F9:0D:81:28'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
/etc/config/wireless

config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'TW'
        option hwmode '11g'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '0'

config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option encryption 'none'
        option ssid 'ReSpeaker1DD45B'
        option seq '1'

config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option network 'wan'
        option ifname 'apcli0'
        option led 'mediatek:orange:wifi'
        option ssid 'UplinkAp'
        option key 'SecretKey'
        option encryption 'psk'
        option disabled '1'

Now I would think that something like this should work:

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'ra0'
        option proto 'static'
        option ipaddr '172.16.100.12'
        option netmask '255.255.255.0'
        option gateway '172.16.100.1'
        option dns '172.16.100.1'
/etc/config/wireless

config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'TW'
        option hwmode '11g'
        option htmode 'HT40'
        option channel 'auto'

config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option network 'wan'
        option ifname 'apcli0' 
        option ssid 'xxxxxxx'
        option encryption 'psk2'
        option key 'xxxxxxx'

But sadly it doesn't. Maybe unrelated, but during a reboot I see this error ERROR!!! RTMPReadParametersHook failed, Status[=0x00000001] and the wan interface doesn't come up on it's own. When I run ifup wan manually the interface is enabled and ifconfig now gives me:

eth0      Link encap:Ethernet  HWaddr 9C:65:F9:1D:C6:2B
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::9e65:f9ff:fe1d:c62b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:138 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:27618 (26.9 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr 9C:65:F9:1D:C6:2B
          inet6 addr: fe80::9e65:f9ff:fe1d:c62b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:7777 (7.5 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:106 errors:0 dropped:0 overruns:0 frame:0
          TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7028 (6.8 KiB)  TX bytes:7028 (6.8 KiB)

ra0       Link encap:Ethernet  HWaddr 9C:65:F9:1D:D4:5B
          inet addr:172.16.100.12  Bcast:172.16.100.255  Mask:255.255.255.0
          inet6 addr: fe80::9e65:f9ff:fe1d:d45b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:589 (589.0 B)  TX bytes:0 (0.0 B)
          Interrupt:6

So almost there, but still no connect apcli0 interface. When it try wictl it does "see" my network and lets me connect to it, after which everything works how I would want/expect it except for the fact that the apcli0 interface does DHCP and gets a random IP instead of my statically configured IP. So how do I config that so it works without these manual steps and uses the static IP? Any ideas/pointers would be very much appreciated! Thanks!

Disable the 'ap' section will do. But before doing that please make sure you can still access the device from wan zone. Failure to do that will likely lock you out from the device.

config wifi-iface 'ap'
    option disabled 1

Thanks for your reply, but I prefer to fix this using the slimmed down config (if possible). Additionally I seem to have the same issue when disabling the AP section, i.e. the WiFI doesn't start up itself and needs manual actions in order for it to start and connect.

I am a bit worried that you will get locked out if you disable the ap wifi-iface (lan network). Please make sure that you can connect through the wan network before moving ahead.

I made some progress. Using the below configs it all works (so with the correct IP addresses) but I still have to manually run ifconfig ra0 up && /etc/init.d/network restart:

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'apcli0'
        option proto 'static'
        option ipaddr '172.16.100.12'
        option netmask '255.255.255.0'
        option gateway '172.16.100.1'
        option dns '172.16.100.1'
/etc/config/wireless

config wifi-device      radio0
        option type     ralink
        option variant  mt7628
        option country  NL
        option hwmode   11g
        option htmode   HT40
        option channel  auto

config wifi-iface sta
        option device   radio0
        option mode     sta
        option network  wan
        option ifname   apcli0
        option led      mediatek:orange:wifi
        option ssid     xxxxxxxx
        option key      xxxxxxxx
        option encryption psk2

So how can I change the config so I no longer have to bring the ra0 interface up manually?

Don't worry about access, as I have a serial connection to the device, so I'm not dependent on the network config :slight_smile:

Previously ra0 was used as AP , now that you removed the whole ap section, I assume you do not need to have it up.

Actually I assume with your current config, it should all work as you want it to be. Have you tried a fresh reboot and confirm that?

Yeah I tried that, but it seems to really need the ra0 interface to be up:

root@ReSpeaker:/# ifconfig
eth0      Link encap:Ethernet  HWaddr 9C:65:F9:1D:C6:2B
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::9e65:f9ff:fe1d:c62b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:134 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:27888 (27.2 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr 9C:65:F9:1D:C6:2B
          inet6 addr: fe80::9e65:f9ff:fe1d:c62b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:7671 (7.4 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:106 errors:0 dropped:0 overruns:0 frame:0
          TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7028 (6.8 KiB)  TX bytes:7028 (6.8 KiB)

root@ReSpeaker:/# ifconfig ra0 up
[   81.640000] efuse_probe: efuse = 10000012
[   81.820000] tssi_0_target_pwr_g_band = 34
[   81.820000] tssi_1_target_pwr_g_band = 35
[   86.480000] <==== rt28xx_init, Status=0
root@ReSpeaker:/# ifconfig
apcli0    Link encap:Ethernet  HWaddr 9E:65:F9:0D:D4:5B
          inet addr:172.16.100.12  Bcast:172.16.100.255  Mask:255.255.255.0
          inet6 addr: fe80::9c65:f9ff:fe0d:d45b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 9C:65:F9:1D:C6:2B
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::9e65:f9ff:fe1d:c62b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:137 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:28250 (27.5 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr 9C:65:F9:1D:C6:2B
          inet6 addr: fe80::9e65:f9ff:fe1d:c62b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:7671 (7.4 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:125 errors:0 dropped:0 overruns:0 frame:0
          TX packets:125 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8508 (8.3 KiB)  TX bytes:8508 (8.3 KiB)

ra0       Link encap:Ethernet  HWaddr 9C:65:F9:1D:D4:5B
          inet6 addr: fe80::9e65:f9ff:fe1d:d45b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:938 errors:0 dropped:0 overruns:0 frame:0
          TX packets:287 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:201800 (197.0 KiB)  TX bytes:0 (0.0 B)
          Interrupt:6

root@ReSpeaker:/#

And even through it looks correct now, it only actually works after doing a /etc/init.d/network restart.

For now I added those two commands to the autorun script so I now at least have something that works. Still would be nice to fix it properly using the configs.

Hmm... I now notice that it now advertises an OpenWrt network :thinking:

Is it possible the device may not be saving the configuration changes?

It does save the configurations. After a reboot or restart the files show the expected content.

More info... If I do ifconfig ra0 up && ifconfig ra0 down && /etc/init.d/network restart it works without advertising any network. So it seems something needs to be loaded which is triggered by ifconfig ra0 up that isn't loaded before:

root@ReSpeaker:/# ifconfig ra0 up
[   81.640000] efuse_probe: efuse = 10000012
[   81.820000] tssi_0_target_pwr_g_band = 34
[   81.820000] tssi_1_target_pwr_g_band = 35
[   86.480000] <==== rt28xx_init, Status=0

Can you post the Kernel log and System log here? Reboot the device and then post it here.

Sure, here they are:

Kernel log:

[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] intc: using register map from devicetree
[    0.000000] CPU Clock: 580MHz
[    0.000000] clocksource_of_init: no matching clocksources found
[    0.000000] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.060000] pid_max: default: 32768 minimum: 301
[    0.060000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.070000] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.080000] pinctrl core: initialized pinctrl subsystem
[    0.090000] NET: Registered protocol family 16
[    0.110000] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.120000] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.130000] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.140000] Switched to clocksource MIPS
[    0.150000] NET: Registered protocol family 2
[    0.150000] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.170000] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.180000] TCP: Hash tables configured (established 1024 bind 1024)
[    0.190000] TCP: reno registered
[    0.200000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.210000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.220000] NET: Registered protocol family 1
[    0.230000] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.250000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.260000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.290000] msgmni has been set to 246
[    0.290000] io scheduler noop registered
[    0.300000] io scheduler deadline registered (default)
[    0.310000] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[    0.330000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[    0.340000] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
[    0.360000] console [ttyS2] disabled
[    0.370000] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
[    0.390000] console [ttyS2] enabled
[    0.390000] console [ttyS2] enabled
[    0.400000] bootconsole [early0] disabled
[    0.400000] bootconsole [early0] disabled
[    0.420000] spi-mt7621 10000b00.spi: sys_freq: 193333333
[    0.440000] m25p80 spi32766.0: found w25q256, expected mx25l25635e
[    0.450000] m25p80 spi32766.0: w25q256 (32768 Kbytes)
[    0.460000] m25p80 spi32766.0: using chunked io
[    0.470000] 4 ofpart partitions found on MTD device spi32766.0
[    0.480000] Creating 4 MTD partitions on "spi32766.0":
[    0.490000] 0x000000000000-0x000000030000 : "u-boot"
[    0.510000] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.520000] 0x000000040000-0x000000050000 : "factory"
[    0.530000] 0x000000050000-0x000002000000 : "firmware"
[    0.600000] 2 uimage-fw partitions found on MTD device firmware
[    0.610000] 0x000000050000-0x000000169a9e : "kernel"
[    0.630000] 0x000000169a9e-0x000002000000 : "rootfs"
[    0.640000] mtd: device 5 (rootfs) set to be root filesystem
[    0.650000] 1 squashfs-split partitions found on MTD device rootfs
[    0.660000] 0x000001b30000-0x000002000000 : "rootfs_data"
[    0.680000] ralink_soc_eth 10100000.ethernet eth0: ralink at 0xb0100000, irq 5
[    0.700000] mt7621_wdt 10000120.watchdog: Initialized
[    0.710000] TCP: cubic registered
[    0.720000] NET: Registered protocol family 17
[    0.730000] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    0.750000] 8021q: 802.1Q VLAN Support v1.8
[    0.770000] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    0.780000] Freeing unused kernel memory: 180K (80323000 - 80350000)
[    2.240000] init: Console is alive
[    2.240000] init: - watchdog -
[    5.310000] usbcore: registered new interface driver usbfs
[    5.320000] usbcore: registered new interface driver hub
[    5.330000] usbcore: registered new device driver usb
[    5.350000] exFAT: Version 1.2.9
[    5.400000] SCSI subsystem initialized
[    5.410000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    5.420000] ehci-platform: EHCI generic platform driver
[    5.630000] phy phy-usbphy.0: remote usb device wakeup disabled
[    5.650000] phy phy-usbphy.0: UTMI 16bit 30MHz
[    5.650000] ehci-platform 101c0000.ehci: EHCI Host Controller
[    5.670000] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    5.680000] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    5.710000] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    5.720000] hub 1-0:1.0: USB hub found
[    5.730000] hub 1-0:1.0: 1 port detected
[    5.740000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    5.750000] ohci-platform: OHCI generic platform driver
[    5.760000] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[    5.770000] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    5.790000] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    5.860000] hub 2-0:1.0: USB hub found
[    5.870000] hub 2-0:1.0: 1 port detected
[    5.880000] platform gpio-leds: Driver leds-gpio requests probe deferral
[    5.900000] MTK MSDC device init.
[    5.950000] mtk-sd: MediaTek MT6575 MSDC Driver
[    5.960000] sdhci: Secure Digital Host Controller Interface driver
[    5.970000] sdhci: Copyright(c) Pierre Ossman
[    5.980000] platform gpio-leds: Driver leds-gpio requests probe deferral
[    6.000000] sdhci-pltfm: SDHCI platform and OF driver helper
[    6.010000] usbcore: registered new interface driver usb-storage
[    6.100000] mmc0: new high speed SDHC card at address aaaa
[    6.110000] mmcblk0: mmc0:aaaa SL08G 7.40 GiB
[    6.120000]  mmcblk0: p1 p2
[    6.130000] platform gpio-leds: Driver leds-gpio requests probe deferral
[    6.270000] usb 2-1: new full-speed USB device number 2 using ohci-platform
[    6.300000] init: - preinit -
[    6.560000] usb 2-1: not running at top speed; connect to a high speed hub
[    6.570000] usb 2-1: config 1 interface 4 altsetting 0 has 2 endpoint descriptors, different from the interface descriptor's value: 1
[    6.710000] usb 2-1: config 1 interface 4 altsetting 0 has 2 endpoint descriptors, different from the interface descriptor's value: 1
[    6.750000] platform gpio-leds: Driver leds-gpio requests probe deferral
[    7.070000] random: procd urandom read with 11 bits of entropy available
[    7.290000] rt305x-esw 10110000.esw: link changed 0x00
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   10.670000] mount_root: loading kmods from internal overlay
[   11.100000] jffs2: notice: (377) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   11.130000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   11.190000] EXT4-fs (mmcblk0p1): recovery complete
[   11.210000] EXT4-fs (mmcblk0p1): mounted filesystem with ordered data mode. Opts:
[   11.230000] mount_root: switched to extroot
[   11.260000] procd: - early -
[   11.270000] procd: - watchdog -
[   11.740000] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts:
[   12.080000] procd: - ubus -
[   13.090000] procd: - init -
Please press Enter to activate this console.
[   15.430000] NET: Registered protocol family 10
[   15.510000] RPC: Registered named UNIX socket transport module.
[   15.520000] RPC: Registered udp transport module.
[   15.530000] RPC: Registered tcp transport module.
[   15.540000] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   15.560000] ntfs: driver 2.1.31 [Flags: R/O MODULE].
[   15.650000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   15.670000] i2c /dev entries driver
[   16.340000] <-- RTMPAllocTxRxRingMemory, Status=0, ErrorValue=0x
[   16.350000] <-- RTMPAllocAdapterBlock, Status=0
[   16.360000] mtk_gpio_wifi gpio-wifi: registering 1 gpio
[   16.410000] i2c-ralink 10000900.i2c: loaded
[   16.440000] Linux video capture interface: v2.00
[   16.530000] hidraw: raw HID events driver (C) Jiri Kosina
[   16.590000] fuse init (API version 7.23)
[   16.600000] Enable Ralink GDMA Controller Module
[   16.610000] GDMA IP Version=3
[   16.640000] *******Enter codec_wm8960_i2c_probe********
[   16.650000] soc-audio soc-audio: ASoC: machine MTK APSoC I2S should use snd_soc_register_card()
[   16.670000] wm8960 0-001a: No platform data supplied
[   16.680000] ****** wm8960_preinit ******
[   17.190000] soc-audio soc-audio: wm8960-hifi <-> mt76xx-i2s mapping ok
[   17.210000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   17.260000] nf_conntrack version 0.5.0 (1975 buckets, 7900 max)
[   17.440000] hid-generic 0003:2886:0007.0001: hidraw0: USB HID v1.10 Device [SeeedStudio ReSpeaker MicArray UAC2.0] on usb-101c1000.ohci-1/input4
[   17.470000] usbcore: registered new interface driver usbhid
[   17.480000] usbhid: USB HID core driver
[   17.500000] usbcore: registered new interface driver uvcvideo
[   17.510000] USB Video Class driver (1.1.1)
[   17.530000] xt_time: kernel timezone is -0000
[   17.550000] PPP generic driver version 2.4.2
[   17.560000] NET: Registered protocol family 24
[   18.520000] usbcore: registered new interface driver snd-usb-audio
autorun
[   50.170000] random: nonblocking pool is initialized
System log

Fri Aug 23 19:28:40 2019 user.emerg syslog: this file has been obseleted. please call "/sbin/block mount" directly
Fri Aug 23 19:28:41 2019 daemon.err block: /dev/mmcblk0p1 is already mounted
Fri Aug 23 19:28:41 2019 daemon.err block: /dev/mmcblk0p2 is already mounted
Fri Aug 23 19:28:42 2019 user.notice root: drv_ralink_cleanup
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'lan' is enabled
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'lan' is setting up now
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'lan' is now up
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'loopback' is enabled
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'loopback' is setting up now
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'loopback' is now up
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Network device 'eth0' link is up
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'lan' has link connectivity
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Network device 'lo' link is up
Fri Aug 23 19:28:42 2019 daemon.notice netifd: Interface 'loopback' has link connectivity
Fri Aug 23 19:28:42 2019 daemon.notice netifd: radio0 (1312): uci: Entry not found
Fri Aug 23 19:28:42 2019 daemon.notice netifd: radio0 (1312): uci: Entry not found
Fri Aug 23 19:28:42 2019 daemon.notice netifd: radio0 (1312): uci: Entry not found
Fri Aug 23 19:28:42 2019 daemon.notice netifd: radio0 (1312): uci: Entry not found
Fri Aug 23 19:28:42 2019 daemon.notice netifd: radio0 (1312): uci: Entry not found
Fri Aug 23 19:28:43 2019 user.notice firewall: Reloading firewall due to ifup of lan (eth0)
Fri Aug 23 19:28:44 2019 user.info syslog: No signal found to connect to
Fri Aug 23 19:28:45 2019 user.emerg syslog: Unknown group "netdev" in message bus configuration file
Fri Aug 23 19:28:46 2019 daemon.info dnsmasq[1412]: started, version 2.73 cachesize 150
Fri Aug 23 19:28:46 2019 daemon.info dnsmasq[1412]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC loop-detect inotify
Fri Aug 23 19:28:46 2019 daemon.info dnsmasq[1412]: reading /etc/resolv.conf
Fri Aug 23 19:28:46 2019 daemon.warn dnsmasq[1412]: ignoring nameserver 127.0.0.1 - local interface
Fri Aug 23 19:28:46 2019 daemon.info dnsmasq[1412]: read /etc/hosts - 1 addresses
Fri Aug 23 19:28:46 2019 user.info syslog: No signal found to connect to
Fri Aug 23 19:28:47 2019 auth.info sshd[1329]: Server listening on :: port 22.
Fri Aug 23 19:28:47 2019 auth.info sshd[1329]: Server listening on 0.0.0.0 port 22.
Fri Aug 23 19:28:47 2019 daemon.info dnsmasq[1412]: reading /etc/resolv.conf
Fri Aug 23 19:28:47 2019 daemon.warn dnsmasq[1412]: ignoring nameserver 127.0.0.1 - local interface
Fri Aug 23 19:28:48 2019 user.info syslog: No signal found to connect to
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Found user 'nobody' (UID 65534) and group 'nogroup' (GID 65534).
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Successfully dropped root privileges.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: avahi-daemon 0.6.31 starting up.
Fri Aug 23 19:28:48 2019 local1.info orangerpcd[1388]: orangerpcd jsonrpc server started (1388)
Fri Aug 23 19:28:48 2019 daemon.warn avahi-daemon[1483]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Loading service file /etc/avahi/services/http.service.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Loading service file /etc/avahi/services/samba.service.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Loading service file /etc/avahi/services/ssh.service.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Joining mDNS multicast group on interface eth0.1.IPv6 with address fe80::9e65:f9ff:fe1d:c62b.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: New relevant interface eth0.1.IPv6 for mDNS.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::9e65:f9ff:fe1d:c62b.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: New relevant interface eth0.IPv6 for mDNS.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.1.1.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: New relevant interface eth0.IPv4 for mDNS.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Network interface enumeration completed.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Registering new address record for fe80::9e65:f9ff:fe1d:c62b on eth0.1.*.
Fri Aug 23 19:28:48 2019 daemon.info avahi-daemon[1483]: Registering HINFO record with values 'MIPS'/'LINUX'.
Fri Aug 23 19:28:49 2019 user.crit mountd[1524]: Starting OpenWrt (auto)mountd V1
Fri Aug 23 19:28:49 2019 daemon.info avahi-daemon[1483]: Server startup complete. Host name is ReSpeaker.local. Local service cookie is 4220725130.
Fri Aug 23 19:28:49 2019 user.crit mountd[1524]: trying to mount /tmp/run/mountd/ as the autofs root
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: could not find a serial number for the device mmcblk0
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: new mount : SD-P2 -> mmcblk0p2 ((null))
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: mounting /tmp/run/mountd/mmcblk0p2
Fri Aug 23 19:28:50 2019 user.crit mountd[1551]: mount -t ext4 -o rw,defaults /dev/mmcblk0p2 /tmp/run/mountd/mmcblk0p2
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: ----------> mount ret = 0
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: could not find a serial number for the device mmcblk0
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: new mount : SD-P1 -> mmcblk0p1 ((null))
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: mounting /tmp/run/mountd/mmcblk0p1
Fri Aug 23 19:28:50 2019 user.crit mountd[1558]: mount -t ext4 -o rw,defaults /dev/mmcblk0p1 /tmp/run/mountd/mmcblk0p1
Fri Aug 23 19:28:50 2019 daemon.info avahi-daemon[1483]: Service "LinkIt Smart7688 SSH on ReSpeaker" (/etc/avahi/services/ssh.service) successfully established.
Fri Aug 23 19:28:50 2019 daemon.info avahi-daemon[1483]: Service "ReSpeaker" (/etc/avahi/services/samba.service) successfully established.
Fri Aug 23 19:28:50 2019 daemon.info avahi-daemon[1483]: Service "LinkIt Smart7688 WebUI on ReSpeaker" (/etc/avahi/services/http.service) successfully established.
Fri Aug 23 19:28:50 2019 user.crit mountd[1524]: ----------> mount ret = 0
Fri Aug 23 19:28:51 2019 user.emerg syslog: autorun
Fri Aug 23 19:28:52 2019 user.emerg syslog: Simple mixer control 'Capture',0
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Capabilities: cvolume cswitch
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Capture channels: Front Left - Front Right
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Limits: Capture 0 - 63
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Front Left: Capture 60 [95%] [-67.00dB] [off]
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Front Right: Capture 60 [95%] [-67.00dB] [off]
Fri Aug 23 19:28:52 2019 user.emerg syslog: Simple mixer control 'Headphone',0
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Capabilities: pvolume
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Playback channels: Front Left - Front Right
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Limits: Playback 0 - 127
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Mono:
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Front Left: Playback 108 [85%] [-13.00dB]
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Front Right: Playback 108 [85%] [-13.00dB]
Fri Aug 23 19:28:52 2019 user.emerg syslog: Simple mixer control 'Speaker',0
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Capabilities: pvolume
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Playback channels: Front Left - Front Right
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Limits: Playback 0 - 127
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Mono:
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Front Left: Playback 102 [80%] [18.00dB]
Fri Aug 23 19:28:52 2019 user.emerg syslog:   Front Right: Playback 102 [80%] [18.00dB]
Fri Aug 23 19:28:53 2019 user.notice TTYD: Starting ttyd service
Fri Aug 23 19:28:53 2019 daemon.info procd: - init complete -
Fri Aug 23 19:29:05 2019 kern.notice kernel: [   50.170000] random: nonblocking pool is initialized
Fri Aug 23 19:29:39 2019 daemon.info procd: Instance filemanager::instance1 s in a crash loop 6 crashes, 3 seconds since last crash
Fri Aug 23 19:30:05 2019 user.crit mountd[1524]: /tmp/run/mountd/mmcblk0p1 has expired... unmounting
Fri Aug 23 19:30:05 2019 user.crit mountd[1524]: finished unmounting
Fri Aug 23 19:30:05 2019 user.crit mountd[1524]: /tmp/run/mountd/mmcblk0p2 has expired... unmounting
Fri Aug 23 19:30:05 2019 user.crit mountd[1524]: finished unmounting

These are the logs without running the manual commands (ifconfig ra0 up) that seems to load the missing stuff needed for the apcli0` interface to work. Probably theradio0 (1312): uci: Entry not found``` has something to do with it, I just don't know what :wink:

Yes I think so the error related to entry not found may be causing the problem. Or tbe problem lies somewhere in the driver maybe thats preventing it to run at startup. Is it possible to change the firmware with OpenWrt latest build like 18.06.4 maybe?

I'm afraid updating OpenWrt is not possible :frowning:

Your config seems okay and the logs seem okay and I think for now your work around is your best bet. Since you cant update the installation there's no way to find out if the problem lies with an old driver build.

Agree... I have a working solution now, so I'm not blocked by this anymore. If someone knows a solution that would prevent me from having to run the ifconfig commands that would be nice, but if not is not a big issue now :+1: