Use of Quest 2 airlink causes internet connection to be lost

my router model is GL-AX1800 and came pre-installed with OpenWRT plus seemingly some proprietary web interface
network topology is as such:

about 30 seconds after starting an airlink session, internet connection is lost on the AX1800's network. used ping from windows and from the router via ssh, both drop connection and router webpage reports 2.4ghz is connected but no internet, but a device connected directly to the WAN AP remains connected to internet, meanwhile airlink connection stays stable and healthy
ive also tried steam link, no change
im really at a loss, this is so unusual, it was working fine just a week or two ago.. ive also tried switching to unstable firmware, no change

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

i dont imagine deep specifics of the firmware are that relevant to my issue, but i found the sourcecode in case it is relevant

The general rule of thumb is that if it's running the GL-Inet firmware, you need to ask them for help. That specific device is not supported at all by the official OpenWrt project, so they are the only ones who know the details of that device and the firmware on it. As a result, support for that product is really their responsibility and it's honestly quite unlikely that anyone is going to read through the source code for that device.

The good news is that they do have a user forum where you can ask your question.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.