[USB] WDR4300 low speed on external storage

I just recently changed my WR1043 v2 to a WDR4300 (both are TP-Link). 1043 has one USB port as I was capable to reach around 10-12 MB/s read speed on middle-grade USB3 flash driver with vsftpd.
4300 has a hub(GL850G) in place, but I couldn't read or write faster than 1.1 MB/s which is USB 1.1 speed. From the resources perspective top doesn't show any bottleneck, as I said the same drive with the same filesystem was 10 times faster. Both the routers are using 19.07 snapshot with the ath79 target.

root@OpenWrt:~# dmesg | grep -i 'usb\|hci'
[    0.152807] GPIO line 22 (tp-link:power:usb1) hogged as output/high
[    0.159814] GPIO line 21 (tp-link:power:usb2) hogged as output/high
[    0.393394] ar7200-usb-phy usb-phy: phy reset is missing
[    6.011611] usbcore: registered new interface driver usbfs
[    6.017322] usbcore: registered new interface driver hub
[    6.022803] usbcore: registered new device driver usb
[    6.056740] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    6.083391] ehci-platform: EHCI generic platform driver
[    6.088995] ehci-platform 1b000000.usb: EHCI Host Controller
[    6.094827] ehci-platform 1b000000.usb: new USB bus registered, assigned bus number 1
[    6.102874] ehci-platform 1b000000.usb: irq 3, io mem 0x1b000000
[    6.134090] ehci-platform 1b000000.usb: USB 2.0 started, EHCI 1.00
[    6.141299] hub 1-0:1.0: USB hub found
[    6.155395] usbcore: registered new interface driver usb-storage
[    6.894112] usb 1-1: new full-speed USB device number 2 using ehci-platform
[    7.136918] usb 1-1: not running at top speed; connect to a high speed hub
[    7.168798] hub 1-1:1.0: USB hub found
[    7.694800] usb 1-1.1: new full-speed USB device number 3 using ehci-platform
[    7.858914] usb 1-1.1: not running at top speed; connect to a high speed hub
[    7.888265] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[    7.904681] scsi host0: usb-storage 1-1.1:1.0

Did anybody experience the same?

Have you tried the old ar71xx target?

not yet, but I dont think it can help so much.
I just rolled back to the original u-boot, but the speed is still the same.

I’m remembering problems with USB on the similar-era Archer C7v2. It was resolved by using a USB hub between the Archer C7v2 and the APC UPS involved. As I recall, it was connectivity at all, but might be worth a shot.

As you note, it may just be the slow, single-core, MIPS-based SoC.

thank Jeff, but I don't really get you.
what kind of usb hub are you talking about between the UPS and the router?
the processor on the Archer C7 has two different USB ports on the processor, while this one has an dedicated hub on the motherboard.
even my old 1043 v1 with a ~400MHz single core MIPS is capable to has write and read speeds around 7-9MB/s.
I think I'll make a downgrade to the ar71xx based target...

It was an unpowered, Anker brand. As I recall, it happened to be USB 3, as USB 2 hubs were fading from the market and as expensive as USB 3.

Here is a pending PR that fixes the low speed on ar934x devices like TP-Link WDR3600/WDR4300

Please test and give feedback.

Fix is accepted and snapshot builds with patches should be created in the next days...