USB tethering configuration help

after i installed luci on my fritzbox with openwrt, i wanted to configure usb tethering. i followed the instructions below:
https://openwrt.org/docs/guide-user/network/wan/smartphone.usb.tethering

however, when i try to log into the network with another smartphone, it does not work. what could be the problem?

Network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd57:6c98:bf45::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option ds_snr_offset '0'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option hwmode '11g'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Fritzbox 7360'
        option encryption 'psk2'
        option key 'testtest'
        option network 'TetheringWAN'

firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option synflood_protect '1'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        list network 'wan'
        list network 'TetheringWAN'

Which network?
Internet, or wifi?

There's a wan zone in the firewall, but no interface for the thethered phone?

with wifi, lan I have not yet tried.

here are the interfaces from luci:

The wiki article is not very good. There's no need to make another network. A tethered Internet connection is straightforward LAN to WAN routing, with the WAN being the virtual port on the phone. Two networks which usually already exist. You just need to install drivers then change the physical device on the wan.

  1. Start from a default configuration or a fresh installation.
  2. If the hardware has more than one Ethernet port, a network named 'wan' already exists. If it's a single Ethernet port device you need to create a network named exactly 'wan' (lower case) of proto DHCP Client.
  3. Temporarily connect the wan network to an available network providing Internet using Ethernet or a wifi client. This includes possibly using the phone's wifi hotspot as the source of Internet.
  4. Download / Install USB tethering drivers.
  5. Connect phone to USB and enable tethering. A new Ethernet-like interface, usually named usb0, should be created.
  6. Change the wan physical device to the USB tether interface.
1 Like

@mk24 it's an old DSL router, there's no physical ethernet WAN port.

He already got it up as a LAN device, so he should be past that point.

Next step is thether, assuming all the packages have been DLed.

here is the list of already installed usb packages:

kmod-usb-core - 5.4.123-1
kmod-usb-dwc2 - 5.4.123-1
kmod-usb-ehci - 5.4.123-1
kmod-usb-net - 5.4.123-1
kmod-usb-net-cdc-ether - 5.4.123-1
kmod-usb-net-rndis - 5.4.123-1
kmod-usb-roles - 5.4.123-1
kmod-usb2 - 5.4.123-1

i think that usb tethering works because my router can connect to the internet through it. but i can't log in through the wifi. it says "IP address is being retrieved...", can it be the firewall setting?

That's because we disabled the dhcps in the old thread.

Re-enable them, and you should be good to go.

what is the command to re-enable dhcp?

uci set dhcp.lan.ignore=0
uci commit dhcp
/etc/init.d/dnsmasq enable
/etc/init.d/dnsmasq restart

Should be enough.

is that correct?

root@OpenWrt:~# uci set dhcp.lan.ignore=0
root@OpenWrt:~# uci commit dhcp
root@OpenWrt:~# /etc/init.d/dnsmasq enable
root@OpenWrt:~# /etc/init.d/dnsmasq restart
udhcpc: started, v1.33.1
udhcpc: sending discover
udhcpc: no lease, failing

it does not work yet

The wifi AP needs to be attached to network lan, not network Tetheringwan. The only thing in the wan network should be the phone.

And by detaching the unused dsl from the existing network wan you could use network wan for the phone and not have Tetheringwan at all.

i think i have completely destroyed the fritzbox. out of my cluelessness i changed the lan interface to dhcp and now i can't connect to the fritzbox at all anymore

if you connect it back to the easybox using LAN-LAN, it should come back, with a new IP.

Thanks, I will try it more tomorrow

how do i find out the new ip address of my router?

Ethernet-Adapter Ethernet:

   Verbindungsspezifisches DNS-Suffix: local
   IPv6-Adresse. . . . . . . . . . . : fd91:dab6:a2b2:1:84ee:76e8:5843:f785
   Temporäre IPv6-Adresse. . . . . . : fd91:dab6:a2b2:1:dd6b:4bf2:e8c6:4108
   Verbindungslokale IPv6-Adresse  . : fe80::84ee:76e8:5843:f785%9
   IPv4-Adresse  . . . . . . . . . . : 192.168.2.141
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Standardgateway . . . . . . . . . : fe80::964a:cff:fe6d:deac%9
                                       192.168.2.1

it should be listed in your main router.

which command can I use to read out the ip?

you need to access the web interface of your easybox, and see who's got which IP assigned.

If you cannot, it's trial and error.

actually it should have the ip 192.168.2.100.

but it does not work either

Unbenannt