USB not working on Linksys EA7300

Confused here.
I bought a new EA7300 router and (thanks bill888) I've installed OpenWrt OpenWrt 21.02.3.
Then I followed the guide before inserting a USB drive. Nothing detected.
I installed the other packages specified into the sister guide page. Nothing detected (tried with several USB drives).
So I started to wonder if the device has the USB port defected.
This is the output of lsusb -t

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-mtk/1p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-mtk/2p, 480M

I tried to revert to the stock firmware to check if with it the USB port is working, but maybe I was not able to hard reset the router three times, because I'm blocked into OpenWrt yet.

Am I missing something to make the USB port working?
If not, can you please describe me how to properly hard reset the router three times?

Thank you.

1 Like

Update: I successfully managed to come back to the stock firmware. The USB drive I've plugged is recognized and it works well.

So, my question is: what have I done wrong, or forgotten, to get USB working in OpenWrt?

P.S.:

root@OpenWrt:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux 5.4.188 xhci-hcd xHCI Host Controller
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.188 xhci-hcd xHCI Host Controller
root@OpenWrt:~# opkg list-installed | grep usb
kmod-usb-core - 5.4.188-1
kmod-usb-ehci - 5.4.188-1
kmod-usb-ohci - 5.4.188-1
kmod-usb-ohci-pci - 5.4.188-1
kmod-usb-storage - 5.4.188-1
kmod-usb-storage-uas - 5.4.188-1
kmod-usb-uhci - 5.4.188-1
kmod-usb2 - 5.4.188-1
kmod-usb2-pci - 5.4.188-1
kmod-usb3 - 5.4.188-1
libusb-1.0-0 - 1.0.24-4
usbids - 0.359-1
usbutils - 013-2
root@OpenWrt:~# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 2
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 5.04
S:  Manufacturer=Linux 5.4.188 xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=1e1c0000.xhci
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev= 5.04
S:  Manufacturer=Linux 5.4.188 xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=1e1c0000.xhci
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms
# dmesg
[    0.000000] Linux version 5.4.188 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16554-1d4dea6d4f)) #0 SMP Sat Apr 16 12:59:34 2022
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is Linksys EA7300 v2
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] On node 0 totalpages: 65536
[    0.000000]   Normal zone: 576 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 65536 pages, LIFO batch:15
[    0.000000] percpu: Embedded 14 pages/cpu s26768 r8192 d22384 u57344
[    0.000000] pcpu-alloc: s26768 r8192 d22384 u57344 alloc=14*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 64960
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes, linear)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Writing ErrCtl register=00000209
[    0.000000] Readback ErrCtl register=00000209
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 250788K/262144K available (6097K kernel code, 210K rwdata, 748K rodata, 1252K init, 238K bss, 11356K reserved, 0K cma-reserved, 0K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 25 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] random: get_random_bytes called from 0x806e7a3c with crng_init=0
[    0.000000] CPU Clock: 880MHz
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4343773742 ns
[    0.000008] sched_clock: 32 bits at 440MHz, resolution 2ns, wraps every 4880645118ns
[    0.007809] Calibrating delay loop... 583.68 BogoMIPS (lpj=1167360)
[    0.042009] pid_max: default: 32768 minimum: 301
[    0.046781] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.054007] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.064438] rcu: Hierarchical SRCU implementation.
[    0.069878] smp: Bringing up secondary CPUs ...
[    6.646768] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    6.646778] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    6.646790] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    6.646891] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.102640] Synchronize counters for CPU 1: done.
[    6.708087] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    6.708095] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    6.708102] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    6.708159] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.167344] Synchronize counters for CPU 2: done.
[    6.769458] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    6.769466] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    6.769474] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    6.769537] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.225203] Synchronize counters for CPU 3: done.
[    0.255081] smp: Brought up 1 node, 4 CPUs
[    0.263614] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.273300] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.280372] pinctrl core: initialized pinctrl subsystem
[    0.287094] NET: Registered protocol family 16
[    0.297938] FPU Affinity set after 4688 emulations
[    0.315184] clocksource: Switched to clocksource GIC
[    0.321527] thermal_sys: Registered thermal governor 'step_wise'
[    0.321990] NET: Registered protocol family 2
[    0.332402] IP idents hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.340516] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.349039] TCP established hash table entries: 2048 (order: 1, 8192 bytes, linear)
[    0.356658] TCP bind hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.363743] TCP: Hash tables configured (established 2048 bind 2048)
[    0.370196] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.376679] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.383860] NET: Registered protocol family 1
[    0.388186] PCI: CLS 0 bytes, default 32
[    0.483157] 4 CPUs re-calibrate udelay(lpj = 1163264)
[    0.489702] workingset: timestamp_bits=14 max_order=16 bucket_order=2
[    0.496596] random: fast init done
[    0.510994] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.516774] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.528263] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.537439] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.543387] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.549199] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.555568] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.565089] printk: console [ttyS0] disabled
[    0.569394] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 19, base_baud = 3125000) is a 16550A
[    0.578381] printk: console [ttyS0] enabled
[    0.586639] printk: bootconsole [early0] disabled
[    0.598472] mt7621-nand 1e003000.nand: Using programmed access timing: 31c07388
[    0.606039] nand: device found, Manufacturer ID: 0xef, Chip ID: 0xf1
[    0.612385] nand: Winbond W29N01HV
[    0.615795] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    0.623354] mt7621-nand 1e003000.nand: ECC strength adjusted to 4 bits
[    0.629902] mt7621-nand 1e003000.nand: Using programmed access timing: 21005134
[    0.637201] mt7621-nand 1e003000.nand: Using programmed access timing: 21005134
[    0.644498] Scanning device for bad blocks
[    1.298112] 11 fixed-partitions partitions found on MTD device mt7621-nand
[    1.304984] Creating 11 MTD partitions on "mt7621-nand":
[    1.310303] 0x000000000000-0x000000080000 : "boot"
[    1.316453] 0x000000080000-0x0000000c0000 : "u_env"
[    1.322732] 0x0000000c0000-0x000000100000 : "factory"
[    1.329054] 0x000000100000-0x000000140000 : "s_env"
[    1.335411] 0x000000140000-0x000000180000 : "devinfo"
[    1.341732] 0x000000180000-0x000000580000 : "kernel"
[    1.348197] 0x000000580000-0x000002980000 : "ubi"
[    1.354399] 0x000002980000-0x000002d80000 : "alt_kernel"
[    1.361148] 0x000002d80000-0x000005180000 : "alt_rootfs"
[    1.367999] 0x000005180000-0x000005280000 : "sysdiag"
[    1.374479] 0x000005280000-0x000007f80000 : "syscfg"
[    1.409837] mt7530 mdio-bus:1f: MT7530 adapts as multi-chip module
[    1.418304] mtk_soc_eth 1e100000.ethernet: generated random MAC address c2:2c:bd:2b:47:ed
[    1.427462] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 21
[    1.437754] mt7621-pci 1e140000.pcie: Parsing DT failed
[    1.445693] NET: Registered protocol family 10
[    1.451680] Segment Routing with IPv6
[    1.455481] NET: Registered protocol family 17
[    1.460022] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.473220] 8021q: 802.1Q VLAN Support v1.8
[    1.479524] mt7530 mdio-bus:1f: MT7530 adapts as multi-chip module
[    1.499582] mt7530 mdio-bus:1f wan (uninitialized): PHY [dsa-0.0:00] driver [Generic PHY]
[    1.509283] mt7530 mdio-bus:1f lan1 (uninitialized): PHY [dsa-0.0:01] driver [Generic PHY]
[    1.519009] mt7530 mdio-bus:1f lan2 (uninitialized): PHY [dsa-0.0:02] driver [Generic PHY]
[    1.528716] mt7530 mdio-bus:1f lan3 (uninitialized): PHY [dsa-0.0:03] driver [Generic PHY]
[    1.538421] mt7530 mdio-bus:1f lan4 (uninitialized): PHY [dsa-0.0:04] driver [Generic PHY]
[    1.548270] mt7530 mdio-bus:1f: configuring for fixed/rgmii link mode
[    1.559511] DSA: tree 0 setup
[    1.562818] rt2880-pinmux pinctrl: pcie is already enabled
[    1.568464] mt7621-pci-phy 1e149000.pcie-phy: PHY for 0xbe149000 (dual port = 1)
[    1.576043] mt7621-pci-phy 1e14a000.pcie-phy: PHY for 0xbe14a000 (dual port = 0)
[    1.683165] mt7621-pci-phy 1e149000.pcie-phy: Xtal is 40MHz
[    1.688743] mt7621-pci-phy 1e14a000.pcie-phy: Xtal is 40MHz
[    1.793956] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    1.800910] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    1.805783] mt7621-pci 1e140000.pcie: PCIE1 enabled
[    1.810662] mt7621-pci 1e140000.pcie: PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.820123] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    1.826491] pci_bus 0000:00: root bus resource [io  0x1e160000-0x1e16ffff]
[    1.833360] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.840227] pci_bus 0000:00: root bus resource [bus 00-ff]
[    1.845747] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.851779] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.858042] pci 0000:00:00.0: reg 0x14: [mem 0x00000000-0x0000ffff]
[    1.864374] pci 0000:00:00.0: supports D1
[    1.868387] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.874548] pci 0000:00:01.0: [0e8d:0801] type 01 class 0x060400
[    1.880592] pci 0000:00:01.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.886856] pci 0000:00:01.0: reg 0x14: [mem 0x00000000-0x0000ffff]
[    1.893179] pci 0000:00:01.0: supports D1
[    1.897191] pci 0000:00:01.0: PME# supported from D0 D1 D3hot
[    1.904372] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    1.912380] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    1.920595] pci 0000:01:00.0: [14c3:7603] type 00 class 0x028000
[    1.926648] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff]
[    1.933048] pci 0000:01:00.0: PME# supported from D0 D3hot D3cold
[    1.940587] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.945825] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.951915] pci 0000:00:00.0:   bridge window [mem 0x00000000-0x000fffff]
[    1.958693] pci 0000:00:00.0:   bridge window [mem 0x00000000-0x000fffff pref]
[    1.965909] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.972738] pci 0000:02:00.0: [14c3:7615] type 00 class 0x000280
[    1.978794] pci 0000:02:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    1.985742] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s x1 link at 0000:00:01.0 (capable of 4.000 Gb/s with 5 GT/s x1 link)
[    2.000953] pci 0000:00:01.0: PCI bridge to [bus 02-ff]
[    2.006190] pci 0000:00:01.0:   bridge window [io  0x0000-0x0fff]
[    2.012280] pci 0000:00:01.0:   bridge window [mem 0x00000000-0x000fffff]
[    2.019058] pci 0000:00:01.0:   bridge window [mem 0x00000000-0x000fffff pref]
[    2.026273] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    2.032924] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    2.039532] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.046483] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    2.053089] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.060044] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    2.066828] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x601fffff pref]
[    2.074042] pci 0000:00:01.0: BAR 8: assigned [mem 0x60200000-0x602fffff]
[    2.080825] pci 0000:00:01.0: BAR 9: assigned [mem 0x60300000-0x603fffff pref]
[    2.088040] pci 0000:00:00.0: BAR 1: assigned [mem 0x60400000-0x6040ffff]
[    2.094825] pci 0000:00:01.0: BAR 1: assigned [mem 0x60410000-0x6041ffff]
[    2.101610] pci 0000:00:00.0: BAR 7: assigned [io  0x1e160000-0x1e160fff]
[    2.108392] pci 0000:00:01.0: BAR 7: assigned [io  0x1e161000-0x1e161fff]
[    2.115180] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff]
[    2.121962] pci 0000:00:00.0: PCI bridge to [bus 01]
[    2.126925] pci 0000:00:00.0:   bridge window [io  0x1e160000-0x1e160fff]
[    2.133712] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    2.140493] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x601fffff pref]
[    2.147712] pci 0000:02:00.0: BAR 0: assigned [mem 0x60200000-0x602fffff 64bit]
[    2.155018] pci 0000:00:01.0: PCI bridge to [bus 02]
[    2.159983] pci 0000:00:01.0:   bridge window [io  0x1e161000-0x1e161fff]
[    2.166760] pci 0000:00:01.0:   bridge window [mem 0x60200000-0x602fffff]
[    2.173540] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff pref]
[    2.181291] mt7530 mdio-bus:1f: Link is Up - 1Gbps/Full - flow control off
[    2.189268] UBI: auto-attach mtd6
[    2.192643] ubi0: attaching mtd6
[    2.561463] ubi0: scanning is finished
[    2.581553] ubi0: attached mtd6 (name "ubi", size 36 MiB)
[    2.587010] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    2.593870] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    2.600643] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    2.607588] ubi0: good PEBs: 288, bad PEBs: 0, corrupted PEBs: 0
[    2.613578] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    2.620785] ubi0: max/mean erase counter: 2/0, WL threshold: 4096, image sequence number: 1650113974
[    2.629899] ubi0: available PEBs: 0, total reserved PEBs: 288, PEBs reserved for bad PEB handling: 20
[    2.639114] ubi0: background thread "ubi_bgt0d" started, PID 501
[    2.640929] block ubiblock0_0: created from ubi0:0(rootfs)
[    2.650645] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    2.657597] hctosys: unable to open rtc device (rtc0)
[    2.670541] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    2.681954] Freeing unused kernel memory: 1252K
[    2.686518] This architecture does not have kernel memory protection.
[    2.692946] Run /sbin/init as init process
[    3.260883] init: Console is alive
[    3.264549] init: - watchdog -
[    4.035660] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.130793] usbcore: registered new interface driver usbfs
[    4.136415] usbcore: registered new interface driver hub
[    4.141828] usbcore: registered new device driver usb
[    4.156504] xhci-mtk 1e1c0000.xhci: 1e1c0000.xhci supply vbus not found, using dummy regulator
[    4.165256] xhci-mtk 1e1c0000.xhci: 1e1c0000.xhci supply vusb33 not found, using dummy regulator
[    4.174237] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    4.179585] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 1
[    4.195313] xhci-mtk 1e1c0000.xhci: hcc params 0x01401198 hci version 0x96 quirks 0x0000000000290010
[    4.204531] xhci-mtk 1e1c0000.xhci: irq 20, io mem 0x1e1c0000
[    4.211601] hub 1-0:1.0: USB hub found
[    4.215451] hub 1-0:1.0: 2 ports detected
[    4.220098] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    4.225452] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 2
[    4.232940] xhci-mtk 1e1c0000.xhci: Host supports USB 3.0 SuperSpeed
[    4.239493] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    4.248453] hub 2-0:1.0: USB hub found
[    4.252320] hub 2-0:1.0: 1 port detected
[    4.262338] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.275558] init: - preinit -
[    4.803233] usb 1-1: new high-speed USB device number 2 using xhci-mtk
[    4.952366] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[    4.960849] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[    4.962719] random: procd: uninitialized urandom read (4 bytes read)
[    4.969385] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    5.122000] random: jshn: uninitialized urandom read (4 bytes read)
[    5.187623] random: jshn: uninitialized urandom read (4 bytes read)
[    5.709432] mt7530 mdio-bus:1f lan1: configuring for phy/gmii link mode
[    5.716469] 8021q: adding VLAN 0 to HW filter on device lan1
[    9.890506] UBIFS (ubi0:1): Mounting in unauthenticated mode
[    9.896408] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 659
[    9.977078] UBIFS (ubi0:1): recovery needed
[   10.204613] UBIFS (ubi0:1): recovery completed
[   10.209214] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   10.217030] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   10.226916] UBIFS (ubi0:1): FS size: 28188672 bytes (26 MiB, 222 LEBs), journal size 1396736 bytes (1 MiB, 11 LEBs)
[   10.237320] UBIFS (ubi0:1): reserved for root: 1331420 bytes (1300 KiB)
[   10.243925] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID 99EFBE24-C3FF-492C-ADF0-4A0BC3C7AC8F, small LPT model
[   10.269502] mount_root: loading kmods from internal overlay
[   10.428078] kmodloader: loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
[   10.696215] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   10.742808] SCSI subsystem initialized
[   10.761978] ehci-fsl: Freescale EHCI Host controller driver
[   10.768945] ehci-platform: EHCI generic platform driver
[   10.777436] ehci-pci: EHCI PCI platform driver
[   10.792821] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   10.800232] ohci-platform: OHCI generic platform driver
[   10.813523] uhci_hcd: USB Universal Host Controller Interface driver
[   10.822003] ohci-pci: OHCI PCI platform driver
[   10.842714] usb-storage 1-1:1.0: USB Mass Storage device detected
[   10.849538] scsi host0: usb-storage 1-1:1.0
[   10.854815] usbcore: registered new interface driver usb-storage
[   10.866319] usbcore: registered new interface driver uas
[   10.872065] kmodloader: done loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
[   11.180448] block: attempting to load /tmp/ubifs_cfg/upper/etc/config/fstab
[   11.194509] block: extroot: not configured
[   11.203077] mount_root: switching to ubifs overlay
[   11.221283] urandom-seed: Seeding with /etc/urandom.seed
[   11.294957] procd: - early -
[   11.297993] procd: - watchdog -
[   11.868864] scsi 0:0:0:0: Direct-Access     Sony     Storage Media    0100 PQ: 0 ANSI: 0 CCS
[   11.880381] sd 0:0:0:0: [sda] 7831552 512-byte logical blocks: (4.01 GB/3.73 GiB)
[   11.888730] sd 0:0:0:0: [sda] Write Protect is off
[   11.893534] sd 0:0:0:0: [sda] Mode Sense: 43 00 00 00
[   11.894357] sd 0:0:0:0: [sda] No Caching mode page found
[   11.899679] sd 0:0:0:0: [sda] Assuming drive cache: write through
[   11.910652]  sda: sda1
[   11.915775] sd 0:0:0:0: [sda] Attached SCSI removable disk
[   12.419367] procd: - watchdog -
[   12.425877] procd: - ubus -
[   12.585084] procd: - init -
[   13.319586] kmodloader: loading kernel modules from /etc/modules.d/*
[   13.370675] ntfs: driver 2.1.32 [Flags: R/O MODULE].
[   13.430504] fuse: init (API version 7.31)
[   13.438805] Loading modules backported from Linux version v5.10.110-0-g3238bffaf992
[   13.446504] Backport generated by backports.git v5.10.110-1-0-g1fbde860
[   13.472196] xt_time: kernel timezone is -0000
[   13.541063] mt7621-pci 1e140000.pcie: bus=1 slot=0 irq=23
[   13.546528] pci 0000:00:00.0: enabling device (0004 -> 0007)
[   13.552216] mt7603e 0000:01:00.0: enabling device (0000 -> 0002)
[   13.558482] mt7603e 0000:01:00.0: ASIC revision: 76030010
[   13.565032] urngd: v1.0.2 started.
[   13.701558] crng init done
[   13.704305] random: 7 urandom warning(s) missed due to ratelimiting
[   14.184484] mt7603e 0000:01:00.0: Firmware Version: ap_pcie
[   14.190080] mt7603e 0000:01:00.0: Build Time: 20160107100755
[   14.219172] mt7603e 0000:01:00.0: firmware init done
[   14.406634] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   14.420388] mt7621-pci 1e140000.pcie: bus=2 slot=1 irq=24
[   14.425909] pci 0000:00:01.0: enabling device (0004 -> 0007)
[   14.431622] mt7615e 0000:02:00.0: enabling device (0000 -> 0002)
[   14.454105] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   14.480095] PPP generic driver version 2.4.2
[   14.485800] NET: Registered protocol family 24
[   14.500639] kmodloader: done loading kernel modules from /etc/modules.d/*
[   14.577103] mt7615e 0000:02:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a
[   14.577103] 
[   14.885837] mt7615e 0000:02:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649
[   14.924035] mt7615e 0000:02:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190121161307
[   20.975339] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[   20.992931] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   21.001357] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   21.005854] device eth0 entered promiscuous mode
[   21.019781] mt7530 mdio-bus:1f lan1: configuring for phy/gmii link mode
[   21.027075] 8021q: adding VLAN 0 to HW filter on device lan1
[   21.036061] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   21.043628] br-lan: port 1(lan1) entered blocking state
[   21.049015] br-lan: port 1(lan1) entered disabled state
[   21.055230] device lan1 entered promiscuous mode
[   21.084133] mt7530 mdio-bus:1f lan2: configuring for phy/gmii link mode
[   21.091875] 8021q: adding VLAN 0 to HW filter on device lan2
[   21.101561] br-lan: port 2(lan2) entered blocking state
[   21.106865] br-lan: port 2(lan2) entered disabled state
[   21.113875] device lan2 entered promiscuous mode
[   21.128792] mt7530 mdio-bus:1f lan3: configuring for phy/gmii link mode
[   21.136114] 8021q: adding VLAN 0 to HW filter on device lan3
[   21.145280] br-lan: port 3(lan3) entered blocking state
[   21.150633] br-lan: port 3(lan3) entered disabled state
[   21.157537] device lan3 entered promiscuous mode
[   21.172302] mt7530 mdio-bus:1f lan4: configuring for phy/gmii link mode
[   21.179818] 8021q: adding VLAN 0 to HW filter on device lan4
[   21.189402] br-lan: port 4(lan4) entered blocking state
[   21.194746] br-lan: port 4(lan4) entered disabled state
[   21.201718] device lan4 entered promiscuous mode
[   21.227080] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
[   21.234336] 8021q: adding VLAN 0 to HW filter on device wan
[   22.594613] br-lan: port 5(wlan0) entered blocking state
[   22.600044] br-lan: port 5(wlan0) entered disabled state
[   22.606322] device wlan0 entered promiscuous mode
[   22.634963] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   22.641918] br-lan: port 5(wlan0) entered blocking state
[   22.647385] br-lan: port 5(wlan0) entered forwarding state
[   22.654642] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   24.166347] br-lan: port 6(wlan1) entered blocking state
[   24.171717] br-lan: port 6(wlan1) entered disabled state
[   24.177756] device wlan1 entered promiscuous mode
[   24.183080] br-lan: port 6(wlan1) entered blocking state
[   24.188480] br-lan: port 6(wlan1) entered forwarding state
[   24.194902] br-lan: port 6(wlan1) entered disabled state
[   25.275857] mt7530 mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
[   25.339766] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx/tx
[   26.411293] br-lan: port 4(lan4) entered blocking state
[   26.416557] br-lan: port 4(lan4) entered forwarding state
[   26.422444] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
[   26.423232] usb 1-1: USB disconnect, device number 2
[   26.429476] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   26.440561] br-lan: port 6(wlan1) entered blocking state
[   26.445939] br-lan: port 6(wlan1) entered forwarding state

Catched:

But no solution. And it isn't a power issue, I have verified.

So, I summarize.

Any connected usb device is not detected.

Another user found that when wan is up, usb is powered down.
I did a test and I confirm that it is so.

Fortunately, I have found a workaround.

I started wondering if this is a hardware issue or a software issue.

So, in luci I reconfigured my interfaces, "detaching" lan1 from the group br-lan and setting lan1 the device of wan and wan6 interface.

And, luckily, it worked! Usb port is not powered down and works as expected!

So the workaround is to use one of the lan ports as wan one in place of the proper wan port.

1 Like

Thank you for the hint, prosit! I don't have enough knowledge about drivers architecture in Linux. So I am in doubt. Is it possible that the ports shuffling may affect the whole system?
Anyway, should this usb issue be reported as a bug now?

Sorry I haven't the technical knowledge to give you a sound answer.
I only know that certain routers allow to treat a lan port as a wan one, and viceversa. Maybe if the hardware cannot manage each lan port singularly there could be an increase in CPU load, but it's only my guess.

Good idea to report the bug and ask for a patch. Can someone indicate what to do?

Same here, no usb function although all required drivers seems to be in.

/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-mtk/1p, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-mtk/2p, 480M
root@Medusa:~#

Have opened a bug report under core, hope some more people check this out.

In can confirm with

[ 0.000000] Linux version 5.10.146 (builder@buildhost) (mipsel-openwrt-linux-
musl-gcc (OpenWrt GCC 11.2.0 r19803-9a599fee93) 11.2.0, GNU ld (GNU Binutils) 2.
37) #0 SMP Fri Oct 14 22:44:41 2022

With both radios enabled dmesg does not show a usb2.0 device being plugged in.
Given that factory firmware supports usb, my suspicion is a kernel config issue. Have other
MediaTek MT7621 noticed this behavior? Other chipsets?

I checked with a mouse, keyboard and usb-lan adapter, that there is no power on the usb outled. So it's disabled by energy rules and not switched on by reboot.

But don't have a clue on which place, the outlet is designef for 1100mA