USB modem, no /dev/ttyUSB

Hey guys,
I'm trying to get my usb dongle to work with TP-Link mr-3420v5 flashed with openwrt.

According to the guide here (, I should see the following dmesg

USB Serial support registered for generic
usbserial_generic 1-1:1.0: generic converter detected
USB Serial support registered for generic
usbserial_generic 1-1:1.0: generic converter detected
usb 1-1: generic converter now attached to ttyUSB0
usbserial_generic 1-1:1.1: generic converter detected
usb 1-1: generic converter now attached to ttyUSB1

or this

scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
scsi 1:0:0:0: CD-ROM            Novatel  Mass Storage     2.31 PQ: 0 ANSI: 0
scsi 1:0:0:0: Attached scsi generic sg1 type 5
usb-storage: device scan complete

however I get neither. And there is no /dev/ttyUSB

I do however see my device when I run cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=02(comm.) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=14db Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=(none)
E:  Ad=83(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=06 Prot=00 Driver=(none)
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Any ideas? Thanks/

Have you installed the drivers? Try
opkg install kmod-usb-net-rndis usb-modeswitch
and if it still doesn't work then look at the links just above Preparations.

Is there any way to identify what protocol your usb modem uses? By connecting the modem to the PC for example?

Not that I know of, but I haven't tried.

Some USB sticks use RNDIS now-a-days which basically is a small router kinda device. It provides DHCP service and if you connect it to router/pc it directly provides internet. You dont need to connect it. It will be identified as an Ethernet interface in the router/pc, just like eth0 or eth1 in Openwrt.

Other devices are basically old modems, they get identified through drivers and once identified they can be connected through UMTS/GPRS/EDGE protocol in the router.

Your settings will differ according to the type of device you have. If you have the RNDIS one, you need to install kmod-usb-net-rndis and if you have modem one you need kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan.

[Edit] If you have enough space on your router, try to install all of them. When your device gets identified, create a new interface and assign it UMTS/GPRS/EDGE protocol and see if your modem gets identified in the config. If not then it's probably RNDIS based.


Small update. I've basically installed all of the drivers I could find (:/) . Now when I plug in my modem and write dmesg I get the following output:

[ 1551.715591] usb 1-1: new high-speed USB device number 5 using ehci-platform
[ 1552.376145] usb 1-1: USB disconnect, device number 5
[ 1552.935676] usb 1-1: new high-speed USB device number 6 using ehci-platform
[ 1553.328811] cdc_ether 1-1:1.0 eth1: register 'cdc_ether' at usb-101c0000.ehci-1, CDC Ethernet Device, 0c:5b:8f:27:9a:64

It's RNDIS based device, you will have an extra interface in Interfaces. Just create a new Interface and in physical tab look for a new ethX.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.