Usb gadget configured and running on raspberry pi 4 but no dhcp address being assigned. How can I get dhcp to assign address on bridged lan?

I have configured usb gadget on my openwrt instance (21.0.2 snapshot) running on my raspberry pi 4. However, I noticed it sees the usb ethernet interface but doesn't assign it and ip address. I have it configured to be bridged to the lan so it could recieve and ip address, similar to how my pc gets one when I connect the ethernet cable, but I keep getting link local (169) addresses. How can I fix this?

current network config (/etc/config/network):

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd65:2fbc:5601::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'usb0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
        option delegate '0'

config interface 'wwan'
        option proto 'dhcp'