Usb fan not working

i have a 12v pc case fan but sadly its not working via router usb port can i connect it to the serial ports or any other way to make it work ?

USB ports are 5v.

what's the DC plug voltage, powering the router ?

1 Like

the problem is that it was working working like charm before and suddenly stopped and still not working even if i tried another fan , another cable , and another usb port in my pc man that's crazy

about the plug it's 12v 2A
the fan 12v 0.38A ( it was working before)

Your fan needs 12 volts and 4.6 watts.
Your router provides 5 volts and 2.5 watts (and that would be only after successful (software-) negotiation, without that, you can only depend on 0.5 watts).

Spot the problem…

many 12 volt fans need at least 7.5 volts to spin up reliably, aging, dust, deteriorating bearings have an impact as well.


the only modification that i did is updating from openwrt 17.1 to 22.2.03 .

what modification should i do plz

You're running a 12v fan off a 5v source, and you're asking us about modifications?

it was working for abou 1 week that's why asking

u said some software negotiation??

No i didn't , but when you tried it someplace else, and it's still dead, one can assume it won't work anymore, or it's b0rked...

when i test it with 12v it works :slightly_smiling_face::slightly_smiling_face: that's crazy

Except for the dc whether 12v or not,you also should consider the starting current of the fan.It usually four times than rated current.


I think the the current is not the problem because the fan pull the current that it needs

Which is exactly the problem @yunhai describes...

1 Like

If the current become nearly or more than the rated of the dc,the volts would goes very low like 5v or less suddently,that may cause your devices dont work

@frollic @frollic @slh
got it fixed all the usb cables that i used were faulty :neutral_face::neutral_face: what i luck i sacrificed a new cable from a charger and it's working now

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.