USB drive stability

Router -> wrt1900ac
Drive -> usb-c 1Tbyte drive with usb2-usbc cable


I have this setup and some problems:

  1. Whenever I reboot the router, the drive comes back rw and fsck.hfs says it cannot repair it. I have to unmount the drive, plug it into my Mac and then replug it to get it working.

  2. Write speed. It seems to be very slow. TimeMachine needs over 30 hours to make a backup. I tried to run bonnie++ to measure performance, but it takes longer than forever to come back with a result (+1 day).

Is this expected and how can I get it to work better?

Bonus question: Is there a way to tell opkg to install package in this usb drive?

Thank you

Have you considered formatting the drive using a filesystem with better support than HFS?

Yes; I considered it.

The worksheets I followed to configure the service and the router advised to use hfs as the file system. I thought that meant openwrt hfs support was mature.
The services I want to run work best on hfs (when hfs works).

Are you affirming that hfs is not reliable and mature on Lede/openwrt and that I am wasting effort trying to get it right?

Thank you.


Same as with Windows filesystems, there is a driver available for HFS and HFS+ but it has low performance and does not support all features.

Which worksheets exactly?

There are multiple; do a search for:

"lede time machine".

I will rebuild. Which fs would be best, fat32?

Thank you

I guess you are sharing the device using netatalk, aren't you? Otherwise (SMB or NFS, for example), the filesystem on the drive would be irrelevant. As @tmomas commented, support for HFS / HFS+ is not very good.

Just to try to figure out where the issue is, I would format the drive using a native Linux filesystem like ext4, then do the speed tests again. I would also test to share the drive using both netatalk and some well supported protocol like SMB (if that meets your needs).

Thanks; I will try that.

On the side, I run bonnie++ (tried to) locally on the router. That should make network irrelevant.

Reporting back:

The switch from hfs -> ext4 made an improvement.
The switch from Netatalk -> Samba 4.6 made a huge improvement:
Samba: full backup is about 6 hours.
Netatalk: It was not done after >12 hours.

Thank you for your suggestions. Waiting on smb 4.8 now.

Does Time Machine work well with a Samba share?

OpenWRT 18.06 with samba4 seems to be very stable. I have been running it for almost a week in two MacBooks with no glitch yet.

1 Like