Hello there!
I have a usb dongle (modem) for 4G LTE connection, but can't access its web-gui via 192.168.0.1 and (another one) 192.168.1.4
What firewall config do I need to have access to web-gui?
Hello there!
I have a usb dongle (modem) for 4G LTE connection, but can't access its web-gui via 192.168.0.1 and (another one) 192.168.1.4
What firewall config do I need to have access to web-gui?
are you sure the UI is accessible once the connection is up ?
https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat
First make sure you have no IP address conflict between LAN and WAN subnets.
Can you ping 192.168.0.1
from OpenWrt console?
If yes, install curl
then execute curl -I http://192.168.0.1
and show result.
What is your modem model?
No, I cannot ping modem.
root@OpenWrt:~# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1): 56 data bytes
^C
--- 192.168.0.1 ping statistics ---
10 packets transmitted, 0 packets received, 100% packet loss
Modem models are:
ZTE mf833n 192.168.0.1
Huawei E3372h 192.168.1.4
Neither is working tho =
on a side note i've tried usbmodeset with no avail.
Yes, It's working from my PC.
There was some firewall rule that provided web-gui, but I've lost it due to bricking and debricking my router.
Let's focus on ZTE for now.
Please show the output of
cat /sys/kernel/debug/usb/devices
cat /etc/config/network
cat /etc/config/firewall
ip a
ip r
root@OpenWrt:~# cat /sys/kernel/debug/usb/devices
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev= 5.15
S: Manufacturer=Linux 5.15.167 xhci-hcd
S: Product=xHCI Host Controller
S: SerialNumber=11200000.usb
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=256ms
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=1405 Rev=59.02
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE Mobile Boardband
S: SerialNumber=123456789ABCDEF
C:* #Ifs= 3 Cfg#= 1 Atr=c0 MxPwr=500mA
A: FirstIf#= 0 IfCount= 2 Cls=02(comm.) Sub=06 Prot=00
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=cdc_ether
E: Ad=87(I) Atr=03(Int.) MxPS= 16 Ivl=32ms
I: If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
I:* If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=10000 MxCh= 1
B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 3.10 Cls=09(hub ) Sub=00 Prot=03 MxPS= 9 #Cfgs= 1
P: Vendor=1d6b ProdID=0003 Rev= 5.15
S: Manufacturer=Linux 5.15.167 xhci-hcd
S: Product=xHCI Host Controller
S: SerialNumber=11200000.usb
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=256ms
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc3:6c9f:a14f::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
list ports 'eth0'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
option dns '192.168.1.1'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
option force_link '1'
option broadcast '1'
option peerdns '0'
list dns '1.1.1.1'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
config interface 'tun0'
option device 'tun0'
option proto 'static'
option ipaddr '172.16.250.1'
option netmask '255.255.255.0'
list dns '1.1.1.1'
option gateway '192.168.1.1'
config interface 'trm_wwan'
option proto 'dhcp'
option metric '100'
config interface 'trm_wwan6'
option device '@trm_wwan'
option proto 'dhcpv6'
config interface 'LTE'
option proto 'static'
option device 'eth2'
list ipaddr '192.168.1.1/29'
option auto '0'
root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-lan state DOWN group default qlen 1000
link/ether 94:83:c4:34:48:47 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 94:83:c4:34:48:48 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.232/24 brd 192.168.1.255 scope global eth1
valid_lft forever preferred_lft forever
inet6 fe80::9683:c4ff:fe34:4848/64 scope link
valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 94:83:c4:34:48:47 brd ff:ff:ff:ff:ff:ff
inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
valid_lft forever preferred_lft forever
inet6 fdc3:6c9f:a14f::1/60 scope global noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::9683:c4ff:fe34:4847/64 scope link
valid_lft forever preferred_lft forever
10: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UNKNOWN group default qlen 500
link/none
inet 172.16.250.1/24 brd 172.16.250.255 scope global tun0
valid_lft forever preferred_lft forever
inet 172.16.250.1/30 brd 172.16.250.3 scope global tun0
valid_lft forever preferred_lft forever
inet6 fe80::20a2:b064:f918:5c6b/64 scope link stable-privacy
valid_lft forever preferred_lft forever
12: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 34:4b:50:00:00:00 brd ff:ff:ff:ff:ff:ff
37: phy1-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
link/ether 94:83:c4:34:48:47 brd ff:ff:ff:ff:ff:ff
inet6 fe80::9683:c4ff:fe34:4847/64 scope link
valid_lft forever preferred_lft forever
40: phy0-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP group default qlen 1000
link/ether 94:83:c4:34:48:49 brd ff:ff:ff:ff:ff:ff
inet6 fe80::9683:c4ff:fe34:4849/64 scope link
valid_lft forever preferred_lft forever
41: phy0-sta0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 96:83:c4:34:48:49 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.229/24 brd 192.168.1.255 scope global phy0-sta0
valid_lft forever preferred_lft forever
inet6 fe80::9483:c4ff:fe34:4849/64 scope link
valid_lft forever preferred_lft forever
root@OpenWrt:~# ip r
default via 192.168.1.1 dev eth1 proto static src 192.168.1.232
default via 192.168.1.1 dev phy0-sta0 proto static src 192.168.1.229 metric 100
172.16.250.0/30 dev tun0 proto kernel scope link src 172.16.250.1
172.16.250.0/24 dev tun0 proto kernel scope link src 172.16.250.1
192.168.1.0/24 dev eth1 proto kernel scope link src 192.168.1.232
192.168.1.0/24 dev phy0-sta0 proto static scope link metric 100
192.168.2.0/24 dev br-lan proto kernel scope link src 192.168.2.1
Reset to defaults and follow
https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_cdc
I've tried setting up modem from wiki with no luck. Although I didn't tried sending manually AT commands due to the fact that there is no serial USB device in my system.
Also I've found snippet from wiki in traffic rules that works
config rule
option name 'Allow-ZTE'
option src 'lan'
option proto 'tcp'
option target 'ACCEPT'
option family 'ipv4'
option dest 'wan'
list dest_ip '192.168.0.1'
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.