USB device mount problem (issue with the size/always 2.00 GB)

I have an issue with USB device (tested with 16GB and 32GB USB devices). Installed packages: block-mount e2fsprogs kmod-fs-ext4 kmod-usb-storage kmod-usb2 kmod-usb3 according to this article + USB device formatted (FS is ext4). I do not know why but the device is always shows like /dev/sda1 2.00 GB (16GB or 32GB USB devices) in luci->System->Mount Points->section Mount Points->Add->Device. If I check the USB device in PC (Windows/Linux installed) there is only one partition 16GB or 32GB (regarding to USB device so it seems OK). Do you have an idea why the USB device size is always 2.00 GB in Mount Points?

What is the output of fdisk -l ?
If you don't have it, install with opkg install fdisk

Device: TP-Link TL-WR1043ND v4.x
OS: OpenWrt 19.07.0

root@OpenWrt:~# fdisk -l

Disk /dev/sda: 28.93 GiB, 31037849600 bytes, 60620800 sectors
Disk model: USB Flash Drive
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x013f2693

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 60620799 60618752 28.9G 7 HPFS/NTFS/exFAT

Doesn't look like ext4...


You have one 30GB partition, marked in the partition table as HPFS/NTFS/exFAT.
It could contain an EXT4 filesystem, and the filesystem could be 2GB or any other size.
Have you tried to actually mount it? What is the results?


I'm new to openWRT but getting use to it.

I have exactly the same issue as the person above with a 128GB stick. I have even tried creating multiple partitions with gdisk and tried various formats such as ext4 and f2fs and whenever it detects them it lists them as 2.00GB in size. I'm using the 19.07 release candidate if that is of any further help?

Please provide this information:


I've downgraded back to release 18 now, but I did do the check you asked before going back and the information was similar to above minus the disklabel stuff.

I've done it all in release 18 as per the guide like release 19 RC1 and now the drive is showing as the correct size at 128GB which leads me to believe it is an issue in release 19.

Sounds like this bug, it's been fixed and should be in 19.07-rc2 i think.

1 Like