Uploading with curl

I'd try the "emergency web interface" again... see if you can get that running.

1 Like

What model and version of DCS-932L do you have?

model and version: A1. DCS-932L

I did and there it is:
Screenshot 2023-01-24 at 05.57.07
So some hope is left :slight_smile:

1 Like

Just flash the factory.bin in the D-Link emergency interface.

You can easily recover from here if something goes wrong.


@account4538 I tried this and it did not work, either. I'm sure I got the right one:


from here:

Screenshot 2023-01-24 at 22.24.14

and the ethernet connection, manually set, is constantly switching between connected and not:
Screenshot 2023-01-24 at 22.29.03

Screenshot 2023-01-24 at 22.30.17

Try to flash


@d687r02j8g thanks a lot. I just tried the file you sent but I have a red light, and the blue lights at the back of camera, the WPS, indicator is one. I got the same output from the Terminal:

curl -F "firmware=@/Users/autumn/Downloads/DCS-932L/openwrt/openwrt-18.06.8-ramips-rt305x-dcs-930-squashfs-factory.bin"
var count = 90;
function init() { countdown(); }
function countdown()
	document.getElementById('WaitInfo').value = count;
	if (count >= 1) setTimeout('countdown()',1000);
	else top.location.href="";
</script></head><body onload='init()'><center><h1>IMAGE UPLOADED SUCCESSFULLY</h1><p>4194304 bytes uploaded.</p><p>The WEB server is shuting down and the firmware updating will start immediately. Please <font color=red><strong>DO NOT POWER OFF</strong></font> the device. And please wait for <input type='Text' readonly id='WaitInfo' value='90' size='3' style='border-width:0; color:#FF3030; text

Do you get an IP address when you set your network card to DHCP?

No, I don't. But the interface keeps switching like i noted in the thread; like it's getting connection (on) and then goes back to (off), and never makes a connection, meaning the indicator never goes to green on the GUI. I'm on OSX, if that helps.

and since I wrote you, first, and the last message, just now, is the time between rebooting the camera. and when i did, it went straight to the red light, and the WPS light is also on.

Are you able to attach a serial cable to see what's happening on the console?

thanks a lot. this I do not have. so, no, I'm not able to.

Can you try pressing the reset button for 10 seconds, apparently that will set the camera to factory defaults

yes, I did this already, before flashing the file you sent. It does go through the procedure, like it's being reset, but then the lights; red, and WPS button lights stay on, after. I know how to reset it, no problem.

So, I reset again, and this time, the switching on the network interface does not happen. and the WPS button is off. but the red light at the front is on. and the interface says: "" and "". So, the server is gone from the camera, as it's not giving an address.

Can you try flashing


From the emergency boot please

Found that link from this thread which you posted in

No problem. can I ask please, how is this different from the last file. never mind your answer, I'm going to flash this latest one, right now.

Do you want me to reset it first, before flashing this new file?

The thread talks about not being able to flash images with a kernel larger than 1MB in size. Seems like the person created a special image to get openwrt running from the emergency web flash? At this point it's worth a shot.

Problem here though is that while not showing up in the bootlog above this partition is actually split into two, and the kernel one is only 1MB in size. So any attempt to flash this device with a kernel bigger than that will fail as long as you do it through the emergency web interface