Upgrading v18.06.5 on Archer C60v3

Hi, I have OpenWrt 18.06.5 r7897-9d401013fc running on my Archer C60 v3 router. Just curious if anyone knows how to upgrade to the latest Openwrt version 23.05.0. I get 'The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.'

1 Like

you can always do one release at a time.


make sure you reset the settings during upgrades.

Doesn't seem to work.

To be clear, it was suggested to upgrade in the following manner:

  • 18 <> 19
  • 19 <> 21
  • 21 <>22
  • 22 <> 23

Which upgrade failed?

You need to use sysupgrade images, 23.05.3 would be an easy try, note you cannot maintain config between 19 and 21, you need to type it back from backup file.

Failed from 18 to 19.



Thanks for the link to install ar71xx to ath79
Here is the system upgrade package I chose:

TP-Link Archer C60 v3
19.07.4 (r11208-ce6496d796)
2020-09-08 18:49:19

It did not work through the gui.

I tried through busybox and it didn't go through:

root@OpenWrt:~# cd /tmp
root@OpenWrt:/tmp# sysupgrade -n openwrt-19.07.10-ath79-generic-tplink_archer-c60-v3-squashfs-sysupgrade.bin
Device archer-c60-v3 not supported by this image
Supported devices: tplink,archer-c60-v3
Image check 'fwtool_check_image' failed.
root@OpenWrt:/tmp# ^C
root@OpenWrt:/tmp# Supported devices: tplink,archer-c60-v3
-ash: Supported: not found
root@OpenWrt:/tmp# Image check 'fwtool_check_image' failed.
-ash: Image: not found

OpenWrt 18 at times drops the 5G signal so I will probably stop at this point and revert back to stock firmware- don't wish to force and brick my device...

You have to force the upgrade.

1 Like

I forced the upgrade in BusyBox to v19 and it... .......................................worked.
I used the gui to upgrade to v22 and all seems ok for now.
Tnx for the help.

Go for 23.05.3. auc or attendedsysupgrade are your friends with low flash upgrades.

attendedsysupgrade is not showing up after install

It is luci frontend for firmware selector....

I think my router has almost run out of memory - any quick solutions?

It should be very minimalistic, you can force attended sysupgrade to move upgraded packages to squasfs

Memory or flash space, two different things ?

Your device is however discouraged.


And will be EOLed after 23.05.


Release 23.x was released without that mention, so one more year of suffering.

They might mention it's been dropped, in the next release notes ,)
"Oh btw, we dropped support for all 8mb flash devices...".

But yes, the info haven't been communicated much, if you ask me.