Upgrading from snapshot to release


I have a Linksys E8450 and I installed openwrt about a year ago. Somehow initially I installed snapshot r18646-3869ccbcc8. I've always been on this snapshot and would like to move to a stable release.
I did something stupid and upgraded to the non UBI version of my firmware. I did do a force upgrade because I thought it was the proper one, but it was not. I've since been able to find the correct firmware for my device but regardless of what I do there seems to be no change. Any advice would be appreciated.

Can you specify exactly which files you've tried to use to upgrade your device?

Have you tried the sysupgrade files?

I have tried every file on this page -> https://firmware-selector.openwrt.org/?version=22.03.3&target=mediatek%2Fmt7622&id=linksys_e8450-ubi . I'm going to system > backup flash firmware > flash image.

I did try the sysupgrade file first, but it didn't seem to make a difference.

Additionally I don't care about saving any configurations or settings I just want to get to a current stable release version.

That makes sense, as a year ago was before there was an official release for these devices.

This one should be what you want:


Am I installing this incorrectly? This is the one that I tried with the steps outlined above but no change is reflected when I go through the process.

Since it sounds like you've done all the right things, I suspect you just have to wait for the DRAM-based pstore files to go away. Unplug the device for a couple minutes and see if that fixes it.

1 Like

Fantastic! That did the trick. Thanks so much for your help!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.