Upgrading 18.06->19.07 / BRN or NOR?

Hello everyone,

because of many router failures, I want to upgrade OpenWRT / firmware of my router. I have 2 questions tho:

  1. Can I use the "Flash new firmware image" Option in Luci to upgrade from 18.06.1 to 19.07.7 directly?

  2. If 1 is true, the firmware selector shows me both a BRN and NOR version. To be honest, I cannot really remember how I installed OpenWRT a couple of years ago. In a previous post on this Forum I said I used
    Since it has brn in it's name, I would assume I should use the BRN version. Is there any way for me to verify that? I couldn't find one in Luci.

btw: I use this router: https://openwrt.org/toh/arcadyan/vgv7510kw22#arcadyan_vgv7510kw22_o2_box_6431

Thank you for your time and help, it is much appreciated :slight_smile:

Yes you can use (and AFAIK the only way? other than going through recovery) the "flash new firmware image" option to upgrade, since it's equivalent to using sysupgrade via command line.

Found this on your device page:

I assume the BRN version says factory while the NOR version says sysupgrade (same as on the device page), if so you can use the sysupgrade image since you already have OpenWRT installed :slight_smile:

See Upgrading 18.06->19.07 / BRN or NOR? - #6 by slh

Just curious, what are the "many router failures"?

1 Like

Thank you for the quick answer :slight_smile: I will use the sysupgrade image and try to upgrade OpenWRT. `

Just curious, what are the "many router failures"?

Wifi stopping to work very often. Sometimes it is unreachable, sometimes Im still in the Wifi Network, but no internet connection is possible. In the Log-File I found the line "Error - Dropping frame due to full tx queue". In this Bugreport I think the solution is to upgrade the OpenWRT / Firmware-Version.

EDIT: Not sure if this needs a new thread, so I'll post it here: When trying to use the sysupgrade.bin File to flash, an error appears "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform." Do you know what that means?

(sha256sum checked successfully)
sysupgrade openwrt-19.07.7-lantiq-xrx200-arcadyan_vgv7510kw22-nor-squashfs-sysupgrade.bin
Device arcadyan,vgv7510kw22-brn not supported by this image
Supported devices: arcadyan,vgv7510kw22-nor VGV7510KW22NOR
Image check 'fwtool_check_image' failed.

(Keine ausgewählt: non chosen, appeared after the error message, I did chose the right file; tried both with keep settings checked, as well as not checked)

I found this on the devices site:
"To have the full 16MB Flash available or to upgrade with a nor-squashfs-sysupgrade.bin image, one needs to flash the full 16MB NOR flash (I tried flashing gluon directly, but it showed that the device arcadyan_vgv7510kw22-brn can't be upgraded with arcadyan_vgv7510kw22-nor image).

Therefore a 16MB firmware image is created based on the nor-squashfs-sysupgrade.bin and your specific board_config, which makes the device compatible with other sysupgrade images."

under "Easy and exhaustive way but without serial". Like I said, I cannot remember how I installed OpenWRT on this Rounter. May this be the cause of the failing update?

You have now found out that you're currently running a brnboot compatible firmware, accordingly you can only upgrade to a(nother) brnboot compatible firmware.

The nor marked images use a completely different flash partitioning, which depends on first replacing the OEM bootloader (brnboot) with u-boot. You can switch to the NOR variants at any time (going back is more difficult and depends on having good backups!), but it requires the full procedure of first replacing brnboot with u-boot.