Upgraded to android pie: netflix and amazon stopped working on OpenWrt's wifi

I've been using openwrt on my wdr3600 for years. Now I'm running 18.6.01 with a pretty straightforward configuration:

  • pppoe adsl wan via external modem
  • many dhcp clients, both via cable and wifi
  • http port forwarding and ddns for a small ARM server

What happens is that since I upgraded my Nokia 6.1 (TA-1043) to Android Pie Netflix and Amazon apps stopped working when the phone is connected via WiFi. This problem is quite hard to diagnose because:

  • all other apps work fine
  • I had no problems with Android 8.1 and the same phone and router setup
  • the two apps work fine when using mobile data instead of WiFi
  • the two apps work fine on other WiFi networks

So the problem must be someway related to Android and Openwrt with these two particular apps. I tried:

  • resetting the router defaults and reconfiguring it
  • changing the MTU
  • disconnecting every other device
  • doing some basic troubleshooting with adb shell on the phone
    but had no success

As a last resort I installed an old Netflix app downloading an apk file from netflix's support center. This version does work but it's outdated and not secure. I don't cosider this a real fix, so...

Any idea or hint?

Thanks!

  • It is likely the Android, as it worked before the upgrade.
  • It could also be that your Android is trying to use an IPv6 DNS server. If you do not have IPv6 Internet, make sure that IPv6 is disabled on the OpenWrt's LAN.
2 Likes

I mostly agree but these app work when using some other WiFi so...

I don't know much about IPv6 since here in Italy its adoption is really modest and my ISP doesn't support. Openwrt has IPv6 out of the box and apparently it does no harm to any other app/device (they get ipv6 addresses but anything works via IPv4 as usual). I haven't disabled it since I trust Openwrt people to chose good defaults. Anyway I'll give it a try. How do I disable it? It's not well documented in the wiki and there are a ton of IPv6 related options scattered here and there so it's not clear how to do so.

In the LuCI web GUI on the LAN:

Screenshot%20from%202018-11-15%2016-31-35

I tried configuring my router following your screenshot but It didn't work. There are other IPv6 settings though (e.g. ULA-prefix) so I'm not convinced I've fully disabled IPv6. Even so killing entirely IPv6 to fix some phone app seems like overkill. There must be some more reasonable workaroud! Or at least I hope so...

In the meanwhile is there something I can do to troubleshoot this weird issue?

I did found the solution: MSS clamping was missing a tick in the firewall tab.

Schermata%20del%202018-11-16%2018-06-58

Now both apps work fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.