Upgrade OpenWRT x86


I am tinkering with OpenWRT as a virtual machine and I kind of like the idea.
For the moment all seem to go well in my experiments, but I was curious about one thing.
How do you upgrade an x86 OpenWRT virtual machine (or even if it is installed directly on the hardware)?

I tried starting a virtual machine with 21.02.7 and installed attended sysupgrade, but it didn't detect a newer version (I never used attended sysupgrade until now, is it the normal behavior? Does it only upgrade between minor versions?).

What would be the smoothest way to upgrade an x86 OpenWRT instance?

I alternate between two installs Sysupgrade help for x86_64 - #14 by frollic

1 Like


The simplest way is to use the squashfs combined image and not touch the image / partition layout (no resizing). Then, the upgrade process is the same as the other embedded devices. Get image, use luci or sysupgrade command to flash it and reboot.

I'm doing this in a VM in proxmox and it's been working great for a few months now (and a lot of "flashing" while I was experimenting with packages)

1 Like

Thank you both for your answers.
I tried the squashfs combined image (without resizing) and I think this is the easiest way to go for me.
Also tried luci-attendedsysupgrade and it seems to work as intended.
For others like me who didn't experiment with luci-attendedsysupgrade until now, if you want to upgrade from one major version to another, you have to check the "Advanced Mode" in the "Configuration" tab "Client" section (the next major version don't show in my case if I don't check this box).

I will fiddle around a little bit more with this new virtualized environment before replacing my current ARM router, but I kind of like it until now.

Thanks again for your help.

Down side is, the storage's underutilized...

I think it's fair to say that this configuration would assume that you would use the left over ressources for others VMs, such as apps that you would eventually install in Openwrt, and so removing the need for more than 100 MB of the default x86 disk size :slight_smile:

True, but as @antoinel said, you could install other virtual machines for other purposes and use the storage like that.

Any idea why the default image is limited to 100 MB? I mean on x86 hardware, this limit doesn't really make any sense. It could have been set to more, so people wouldn't have to resize it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.