Upgrade of TP-Link TL-WR1043ND v1.8 from 15.05.1 to LEDE 17.01.4 failed at restoring config

I have tried to upgrade my TP-Link TL-WR1043ND v1.8 from 15.05.1 to the latest LEDE 10.01.4 release following the procedure found at: https://openwrt.org/docs/guide-quick-start/sysupgrade.luci
Everything went well, and I could even install the packages that I used on the previous release that include:
It all seems to be working well enabled in startup.
Then I went to the last step in the procedure - i.e. to restore the backuped config.
After that came up, I could access the router only from wifi computers, and I could not browse or ping to anywhere on the internet (WAN).
As I could not leave my network not operational for too long, I just flashed back the previous release, installed the old packages, and restored the backup. So now I'm back to where I was.
As I have a lot of details in my installation, it would be a nightmare for me if I have to restore my configuration manually.
Before trying to do the upgrade again during some time when I will have more time to collect detailed debugging information, I wanted to ask:

  1. Is there something basic I am doing wrong here?
  2. What debug information I need to look for the next time I make this attempt?
    Many Thanks.

Most likely the network config and/or switch config have changed so much that your old config does not work ok. It would be better to do changes to /etc/config/network by hand. Also firewall and system may have more significant changes. Generally most other config files should be ok.

If you look at the backup archive, it is a normal tar.gz archive. You can easily expand individual files from that without fully "restoring config". Then you can compare those with diff, and do the few changes by hand. You should be able to use most of the other config files just as they are.

Alternative: restore config but do NOT reboot. Manually delete /etc/config/network and /etc/config/system, and then reboot. Those two files will be re-created at the next boot, if they are missing.

1 Like

Thank you hnyman. I like the idea of:

I will try it in a couple of days, when I could take done the system comfortably with no haste, and will update with the results.

I tried the "alternative" procedure and it did not work, or at least it is not as straightforward as it appeared to me, and probably some more manual configuration adjustment would be required.
I guess a manual reconfiguration is inevitable.
I also guess that the documentation in https://openwrt.org/docs/guide-quick-start/sysupgrade.luci should be modified to reflect this complexity, and warn others who might try to simply restore config.