Upgrade fail from 15.05 to 18.06


#1

HI All,

using

root@OpenWrt:~# cat /etc/openwrt_release 
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='Chaos Calmer'
DISTRIB_REVISION='unknown'
DISTRIB_CODENAME='chaos_calmer'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer 15.05'
DISTRIB_TAINTS='no-all no-ipv6 busybox

this device currently build-ed same target firmware with openwrt 18.06 and boom no error while upgrading but device not able to come up.

any suggestion over here as i suspect its kind of partition issue while upgrading a firmware .


#2

You will probably need to reconfigure going from v15 to v18 or v19. Have you tried not keeping settings on the device (after making a backup and saving it somewhere safe, off the device)?

Which device?


#3

yes i tried with not keeping settings.

does there is a difference with UI upgrade or upgrade from shell i am using below command.

"sysupgrade -n /tmp"

its GL AR 300M .


#4

With or without NAND?

As I recall, anode chech the GL.iNet forums, you may need to use U-Boot to “cross-grade” from NAND to NOR. I don’t recall if OpenWrt has a NAND version of the firmware for v18.


#5

NOR flash only.

openwrt-ar71xx-generic-gl-ar300m-squashfs-sysupgrade.bin (file name)


#6

Should upgrade smoothly. Perhaps the wrong socket for the Ethernet or that OpenWrt uses 192.168.1.1 (different than GL.iNet default) and the wireless is off?


#7

i kept default wireless is on in code, with custom SSID i wont be able to see anything .