Updating miniupnpd from latest source from master branch

I download the source from miniupnp directly from master branch wrapped it up in a tar.gz and placed it in the dl folder i got my source from here:
miniupnp/miniupnp: UPnP IGD implementation (github.com)

I then updated the makefile with a new signature of the zip file in the feeds folder.

I get an error when trying to build using make package/miniupnpd/compile V=s saying:

*** No targets specified and no makefile found. Stop.

Any idea what im doing wrong I'm new to openwrt.

Do I have to edit the makefile in my newly created tar.gz file as it has several in there from different platforms do I have to rename the makefile.linux to just make file or something ? but I guessed it ignores this and uses the makefile in the feeds of github?

I guess I'm a little lost in file structures and makefiles and how the complete build process works and where everything is.

AFAIK all source files are automatically downloaded by the build system according to the package makefile.

net/miniupnpd: update to 2.2.1

Yes is does download the source but if the source is present in the dl folder it seems to skip downloading it.

All I have done is downloaded updated source put it in the same named archive file and patched the hash in the makefile in the below location:



I think you're missing a d and adding a redundant s. You should call it like this:

$ make package/miniupnpd/compile V=s

So no S, and miniupnpd.

1 Like

yes you are correct I did do that it is just my rough forum post I have updated my first post to reflect this.
If i put back the old source tar.gz and hash in the makefile it builds correctly Just not with the new sorce or hash so there must be something I'm missing or something I have to configure
It seems to unzip my source into the target folder apply patches to the target.linux files and a few others then it fails with build error.

If I dont update the makefile hash with the new source it fails the hash check and stops make.
could it be the sources make file dependances like gcc or ?

You should be able to use the skip variable:


It pases the hash it extracts the source into the target folder it paches the makefile in the target folder with the patches in the feeds folder, i'm lost as into why it wont work.

Make sure you have the package enabled in the OpenWrt configuration (make menuconfig). It won't build if it's disabled, even standalone.

Yip it is definatly selected.

I'm lost as into why it wont work i think i wil try chmod 777 before I archive the source as a last resort I can't think of any thing else.

That is what it was all the files I downloaded had the incorrect premissions it works straight away after recreating the achive man now I feel silly but I found my problem thanks everyone :slight_smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.