Update list error

Hello,
It's been a while sinds i installed OpenWrt on my TP-link AC750 and i feel like a total newby again. I hope you guys can help me.
Now i'm trying to get the ipTv working, so im trying to get the multicast an IMGPproxy working. However...

I'm stuck at updating my packages list (go figure..)

this is the message i get when i click the 'update list' button:

Downloading http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/packages/Packages.gz

Downloading 
*Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/base/Packages.gz
*** Failed to download the package list from *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/base/Packages.gz

Downloading 
*Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/luci/Packages.gz
*** Failed to download the package list from *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/luci/Packages.gz

Downloading 
*Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/packages/Packages.gz
*** Failed to download the package list from *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/packages/Packages.gz

Downloading 
*Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/routing/Packages.gz
*** Failed to download the package list from *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/routing/Packages.gz

Downloading 
*Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/telephony/Packages.gz
*** Failed to download the package list from *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/telephony/Packages.gz

Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:1: Ignoring invalid line: `config igmpproxy'
 * opkg_conf_set_option: Unrecognized option: quickleave=1
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:4: Ignoring invalid line: `config phyint'
 * opkg_conf_set_option: Unrecognized option: network=wan
 * opkg_conf_set_option: Unrecognized option: direction=upstream
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:7: Ignoring invalid line: `        list altnet 0.0.0.0/0'
 * opkg_conf_parse_file: /etc/opkg/customfeeds.conf:9: Ignoring invalid line: `config phyint'
 * opkg_conf_set_option: Unrecognized option: network=lan
 * opkg_conf_set_option: Unrecognized option: direction=downstream
 * opkg_download: Failed to download *Link- cant put more than 2 links in*/releases/18.06.1/targets/ramips/mt7620/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download *Link- cant put more than 2 links in*/releases/18.06.1/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

Hope you can help
Greetings
Steven

There shouldn't be config stuff in the customfeeds file. Maybe your overlay file system is messed up?

how can i solve this. Should i just empty my customfeeds file?

Could you post here the contents of the file?

It's format is pretty straight forward

src/gz example_feed_name http://www.example.com/path/to/files

Most likely you overwrote it with something else.

I think i might have.. its nothing of the sort
Here is the customfeeds.conf:

config igmpproxy
        option quickleave 1

config phyint
        option network wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan
        option direction downstream

This is the distfeeds.config:

src/gz openwrt_core http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/packages
src/gz openwrt_base http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/telephony

Delete the contents and try again.
Distfeeds looks good.

1 Like

The syntax of your customfeeds.conf was completely wrong. It should look something like

src/gz example_feed_name http://www.example.com/path/to/files

Your entry looks more like it was supposed to go into /etc/config/network.

1 Like

So i put the stuff from customfeeds into the Network file. which made more sense...
Customfeeds.conf is now empty...

It now looks like this when i try to update the list (the same minus the removed errors)

Downloading http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/base/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/luci/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/luci/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/routing/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/routing/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/telephony/Packages.gz
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/targets/ramips/mt7620/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

You can't just put config stuff in files without having any clue about what it does or where it should go. It's hard to guess what else is wrong so you would probably save time by resetting the router to the default settings and starting over. See https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#factory_reset

4 Likes

This might just be the best option. Well case closed for now. Thnx everyone

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik


(BTW, that content appears to be a config from a file named igmpproxy.conf - used by the igmpproxy package.)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.