(Update: Likely Not OpenWRT Issue) Diagnosing Router Restarts -- Linksys EA6350v3 running 19.07

Hey all!

First, sorry if some of my vernacular is off. I'm a software engineer, but not a home networking expert.

Also, full disclosure, I posted this same question on reddit. I was directed to this thread in the comments, but I suspect my issue my different since I was experiencing it over wifi.

I have a Linksys EA6350v3. It was consistently restarting under "heavy" (6 devices across both wireless signals, speeds around 40 mbps divided between all devices) loads. I'd connect my computer wirelessly and start updating a game -- no problem. Then I'd connect my PS4 wirelessly and start updating. A minute later I'd experience a restart.

I flashed OpenWRT 19.07 and tried to the same pattern: connect computer and update, then connect ps4 and update. Again, a minute or so after both devices connected, it restarted again.

I watched the logs while this happened and nothing notable seems to happen. I've attached system and kernel logs. The restart occured around 17:04 on the system logs. I connected both PC and PS4 at ~10:00. Also started streaming videos on youtube to poke the system into failing again if that's relevant.

System: https://pastebin.com/JqxNCMFmK
Kernel: https://pastebin.com/itexJ1u4

I tried flashing stock as well, and was experiencing the same issue, though seemingly more often if anything :thinking:

Any help would on diagnosing this would be sick!

If you're seeing the same issue while running the stock OEM firmware as well, this would suggest a defective device - usually one would close the issue here and start the warranty replacement procedure (after flashing back the OEM firmware, of course).

Things you might be able to look at:

  • replace kmod-ath10k-ct with kmod-ath10k-ct-smallbuffers, to reduce memory pressure with many concurrent clients a bit.
  • check that the PSU is o.k. (enough power, no voltage drop under load - maybe testing a compatible one --> same voltage/ polarization and plug type, at least the same current figures or better)
  • check for overheating, maybe also opening the case and directing a fan into the device (this will void the remains of your warranty, so consider the replacement route before).

Hey, thanks for the reply! I'll check that stuff out. I was worried a hardware issue may be the next step :frowning:

I recognize now this is getting further and further away from being an OpenWRT issue, so no sweat if this needs to be closed.

I will add a final bit of strangeness if it elucidates anything obvious I should try:
I realized that I have a second router provided by my ISP, which also seems to experience these restarts. Usually I'd say this points to a modem issue, but the routers are actually restarting, not simply losing connection (per the logs). Is the modem able to cause router restarts consistently across different firmwares + different hardware? I will also contact my ISP today to see if they have anything on there end.

Another possibility (as hinted at by @slh) is that when the routers are unable to draw the required power from the outlet. I may need to get another device to check if this is the case, but it does seem to be a possible explanation.

Thanks for the help!

What is the second router (the ISP one?)
Also ipq806x or ipq40xx based? (or something quite different?)

Just thinking that there have been reports on ipq806x routers crashing after seeings in the logs a few messages possibly related to jumbo frames.
See e.g.

ipq806x-gmac-dwmac 37200000.ethernet eth0: len 1675 larger than size (1536)

That is pure guess, but an example of weird things that can happen in some conditions. If the ISP modem send jumbo frames that get mishandled by the router, there might be crashes.