Unifi UAP v1 OpenWrt installation possible?

Hello !
I have several Unifi UAP v1. They all first came with a custom firmware from the Wifi provider we have (and I plan to cancel), which is a custom of either OpenWRT or ddWRT, I don't remember. I took one of them down and wanted to bring it to factory default, and had a great difficulty, with all tftp and stuff I didn't make it to work, that's how I got introduced to OpenWRT in the first place: instead of bringing it to Unifi default, I installed OpenWRT, as suggested by a good friend.

But after a while I did manage to flash it with Unifi firmware (one point was just wrong in the Unifi guide for it). I brought all of them to Unifi default.

Now, I want to use one of them outside the Unifi network, so I tried to install OpenWRT back again..... and, it doesn't work !!
I am aware of "blockage" on UAP v2 from this page:

But I thought, since my UAPs are older, and it used to have a custom of xxWRT, one of them even OpenWRT installed by me, it should be possible. Shouldn't it be ?
Or, is the blockage of "v2" about the firmware ? Does that mean, since my UAPs now all got Unifi firmware 4.3.20, OpenWRT will be rejected in eternity ? I also tried to downgrade to 3.7 first. But it doesn't seem to make it better.

I would much appreciate information: if it's known to be impossible, I'm not going to spend time on it anymore. It's not soo bad if it's stuck in Unifi firmware.


Once 4.x factory firmware has been installed, the only way to initially install OpenWrt is with a serial port. Once OpenWrt is running, you can do conventional sysupgrades to new versions, without a serial port.

The 4.x upgrade also replaces the bootloader with one that will only accept signed firmware via pushbutton TFTP recovery. Pushbutton TFTP will no longer work with the OpenWrt "factory" image since it is not signed.

The ubnt_unifi build in ath79/generic is the one for this model. Download the initramfs version and place it in a TFTP server on your PC. Log into the bootloader by serial and manually TFTP the initramfs to RAM at 0x81000000 and boot it (bootm 0x81000000). This is OpenWrt in RAM, which you then use to install the sysupgrade file into flash. The "factory" image is not used in this process.

Not all release directories have an initramfs image, so if you don't find it, go to the snapshot directory. You can sysupgrade to a release OpenWrt from snapshot.

A few months ago, Ubiquiti declared these old models end of life, and the the Unifi controller no longer supports it. So third-party firmware is necessary to make continued use of it.

Dear Mk24

Thank you very much for the information. I did know that these old models are "not supported", but I didn't realize that they are going to be unusable on Unifi Controller sometime soon: so far they are working fine on the Controller, I just have to endure having to look at the message that they are EOL devices every time I start the controller. Do you know when they would stop working ?

I was rather scared of serial flashing but I hate to throw away usable things, I would have to look into it.... I wonder why nobody has a copy of an old firmware...


p.s. meanwhile I found by myself how/when these old APs stop working: if I don't update the controller beyond Feb 2021, then they keep working and remain open to configuration. So it's a matter of if the necessity of updating arises at some point...