Understanding the Options in the Web Interface

Hi all,
I have been running Gargoyle on a couple routers for many years, the last being a TP-Link Archer C7 V3. That router is getting rather long in the tooth and getting unreliable so I purchased a BananaPi-R3 and installed the included version of OpenWRT. I have been trying to setup my network but I don't understand all of the options that are available in the Web Interface. Is there a document that lists what each of these options are and what they do? I'm not even sure how to search for the information as I'm not sure if they are standard OpenWRT items or something custom from BananaPi.
Initially, I am looking at all of the options available under the MTK -> WiFi Configuration screen.

1 Like

Welcome to the community.

This is definitely not official OpenWrt. In official OpenWrt, the WiFi config is under Network > Wireless.

Try: https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/openwrt-mediatek-filogic-bananapi_bpi-r3-sdcard.img.gz

BTW, you'll have to install the LuCi web GUI:

opkg update
opkg intall luci

For reference, see: https://openwrt.org/toh/sinovoip/bananapi_bpi-r3#installation

I figured the information was moved to a new location, but I'm more looking for information on the options I see. Is there a reference for OpenWRT that describes what the different options are and such? For instance, here are some of the things listed in the network setup for the 2.4GHz network:
6. MTK
6.1. WiFi Configuration
6.1.1. MT7986 Configuration MT7986.1.1 Interface ra0 Configuration Basic SSID Auth Mode Disable OPEN Enhanced Open SHARED WEPAUTO WPA2 WPA3 WPA3-192-bit WPA2PSK WPA3PSK WPAPSKWPA2PSK WPA2PSKWPA3PSK WPA1WPA2 IEEE8021X Encryption WEP TKIP TKIPAES AES GCMP256 Key Renewal Interval MFPC MFPR MFPSHA256 Hidden AP Isolation WMM Capable TX Rate STBC HT LDPC VHT STBC VHT LDPC Mode 1 – B only 4 – G only 9 – B/G/GN mode 16 – HE_2G mode 0 – B//G mixed DLS Capable APSD Capable Fragment Threshold RTS Threshold VHT Short GI VHT BW Signaling HT Protection HT Guard Interval Long Short Auto Operating Mode Mixed Mode Green Field A-MSDU Auto Block ACK IGMP Snooping HE_MU DL OFDMA UL OFDMA DL MU-MIMO UL MU-MIMO WPS WDS Stations Interface apcli0 Configuration MT7986.1.2 Configuration Interface rax0 Configuration Basic SSID
The bullet numbering was from my attempt to map out the options so I could figure out what all of the terms mean. Some of them I understand. Others are new to me.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

I don't think its a problem with either how OpenWRT works, or how this particular implementation works. I am looking for information on what these options mean. I originally came to OpenWRT looking for the information since I know it has a large community and I was hoping there was a list of all the menu items in OpenWRT. Unfortunately I have not been able to find any of this information in the OpenWRT wiki. I'm still looking but I was hoping someone knew where it might be.
Again, this is not a problem report. I am looking for basic WiFi option explanations. I have found some information but it seems to be older.
Thanks again!

You noted/concluded that your device is not running official OpenWrt - hence what you listed can't be OpenWrt's menu items. I'm not sure how we could provide information on someone else's menu - maybe you can expound?

Perhaps I've mistaken or misread. I apologize for any confusion on my part. Perhaps others can chime in with more relevant info.

I'd think that performing a web search for these generic WiFi terms would produce good results. Additionally, I can offer our WiFi Wiki (:spiral_notepad: again, I'm not sure the Wiki could assist you):

I hope this helps, and I wish the best for your setup.

Yes, this is what I was looking for. I didn't find it looking through the wiki table of contents. It includes many of the terms I was looking for.
Thank you.

1 Like

The web based interface for OpenWrt called luci ( short for something like lua based uci ) has a lot of descriptions on many of the settings items. More detailed info on each may be in the wiki or found on the internet at standards organizations etc.

1 Like

So, looking through the pages from the Wiki provided above, and reading more on the BananaPi forums, it seems I may be better off loading an OpenWRT snapshot image for the BPi-R3. I'll try that and see if it alleviates some of my confusion.

  1. OpenWrt documentation could indeed be better. While LuCI features many descriptions, those are not always self-explanatory and already require an advanced understanding of the topic at hand. Many of the options in the interface can only be understood by beginners if they search the web.

  2. In my personal opinion, the main problem is: keeping the OpenWrt documentation up to date requires significant effort. The OpenWrt documentation is vast. There are so many complicated guides out there that show you complex configurations and because these configurations are so complex and require multiple user inputs along the way, sometimes it is easier for advanced users to configure it via commandline rather than the user-interface. Especially since OpenWrt development is ongoing, things change from time to time and not all config options may be added to LuCI.


  3. users can install packages that add additional features to OpenWrt and may change how the user-interface looks too, but let's assume this is just another subproblem of the "OpenWrt is too vast" problem

1 Like

That means it's running the mediatek drivers, not the open mt76 driver used in official OpenWrt. The wireless configuration will be completely different.

1 Like

Finally got the snapshot up and running on the router. Looks nice and is fast. Unfortunately, it looks like luci-app-samba4 is incompatible with the architecture of the router, so, no media sharing yet. My old router has 2 x 2TB USB HDDs on it with the documents and such for the house served from it.

You should give samba4 another try now. It wasn't compiling on snapshot for a while but it was fixed in the last few days.

I gave it a try and it loads but there were errors. It appears that some of the kmod-usb components wanted the newer kernel from the newer snapshot. I tried the sysupgrade through luci but the router didn't come back up. When I used the serial monitor, it looks like it is looking for the backed up settings file over tftp but I don't know how to send it to the router.
So, I downloaded the newer snapshot for the SD card and that loads, but for some reason I cannot copy it onto NAND anymore.

spi-nand: spi_nand spi_nand@1: Winbond SPI NAND was found.
spi-nand: spi_nand spi_nand@1: 128 MiB, block size: 128 KiB, page size: 2048, OOB size: 64
jedec_spi_nor spi_nor@0: unrecognized JEDEC id bytes: 00, ef, aa
'spi-nand0' is now active device
* spi-nand0
  - device: spi_nand@1
  - parent: spi@1100a000
  - driver: spi_nand
  - type: NAND flash
  - block size:        0x20000 bytes
  - page size:         0x800 bytes
  - OOB size:          64 bytes
  - OOB available:     24 bytes
  - 0x000000000000-0x000008000000 : "spi-nand0"
  - 0x000000000000-0x000000080000 : "bl2"
  - 0x000000080000-0x000000380000 : "factory"
  - 0x000000380000-0x000000580000 : "fip"
  - 0x000000580000-0x000008000000 : "ubi"
Press ENTER to return to menu
  • What does dmesg say?
  • Try a new snapshot as it may change daily?
  • Try a new sd card as per @dangowrt's suggestion?
  • Try reformatting the sd card?
  • Try exercising those dipswitches? I never trust those things.
  • Another suggestion I saw was to completely unplug everything/power down the device.

I also find myself questioning whether or not the nand has been erased correctly by the software during a new install attempt. There are a few posts covering that on the banana pi forums.

Here is another one dealing with sd card nand issues.

Sorry these are kind of redundant ctl-c / ctl-v answers. I'm considering getting a bpi-r3. I just wish it booted off USB to avoid all this - or maybe a m2 ssd.

The mini should be interesting not sure where they are with that.

Thanks for those links. I didn't find them in my searching. I bow to your google-fu.
It looks like I have a problem with either the SD card itself, or with the image. The first boot works fine but as soon as I reboot I get:

Using ethernet@15100000 device
TFTP from server; our IP address is
Filename 'openwrt-mediatek-filogic-bananapi_bpi-r3-initramfs-recovery.itb'.
Load address: 0x46000000
Loading: *
ARP Retry count exceeded; starting again
Wrong Image Format for bootm command
ERROR: can't get kernel image!

So it looks like the image is corrupted somehow, This is after typing reboot in the SSH terminal.
I did notice some errors just before that which might tell me what the problem is:

CPU:   MediaTek MT7986
Model: BananaPi BPi-R3
DRAM:  2 GiB
Core:  52 devices, 24 uclasses, devicetree: embed
jedec_spi_nor spi_nor@0: unrecognized JEDEC id bytes: ff, ef, aa
MMC:   mmc@11230000: 0
Loading Environment from MMC... OK
In:    serial@11002000
Out:   serial@11002000
Err:   serial@11002000
reset button found
Loading Environment from MMC... *** Error - No Valid Environment Area found
*** Warning - bad env area, using default environment

Net:   eth0: ethernet@15100000
** No partition table - mmc 0 **
Couldn't find partition mmc 0:4
Cannot read EFI system partition
Cannot read EFI system partition
Failed to persist EFI variables
Saving Environment to MMC... Writing to redundant MMC(0)... mmc write failed
Failed (1)
Saving Environment to MMC... Writing to redundant MMC(0)... failed
Failed (1)
1 Like

Alright. I did a full scan of the SD Card including multiple full write-read with badblocks. The SD card tests fine. I reflashed the image to the SD card and the same error occurs on reboot. I cleaned the SD card again and booted the router, but this time I went straight to copy to NAND. The copy worked and the image runs fine from NAND. Not sure what the problem is exactly, but it appears that the 25 May 2023 SD card image does not work with an SD card.
I have done multiple reboots and installs from the NAND copy of the same image and it is running fine.
Thanks for all the help.

1 Like