UnBricking Netgear R6350

I have uploaded openwrt-19.07.5-ramips-mt7621-netgear_r6350-squashfs-factory firmware from OPENWRT to my router using the vendor software provided my my router. Following the update, I no longer can access my router.

I have unsuccessfuly tried to revert back to my stock firmware using instructions at https://kb.netgear.com/000059633/How-to-upload-firmware-to-a-NETGEAR-router-using-TFTP-client without success.

I also tried the command line interface for TFTP.
C:\Users...\Desktop\orignal\R6350_V1.1.0.78_1.0.1> tftp -i put R6350.img
Connect request failed

Any help I get would be appreciated.

Following may be of interest: nmrpflash - Netgear Unbrick Utility

1 Like

The power LED needs to be yellow (blinking or solid depending on the model) for TFTP to work. Power up while holding the reset button down to force entry to TFTP recovery.

Though I think someone else also said that only nmrp worked on their 6350.

At no point did I see a yellow or orange light.
I don't know what I did wrong to get to this point. There was no power interruption. I double checked the firmware file name. It was never flashed with non stock firmware, so I used the ...factory option. I was interested in perhaps installing PIHole software in the router and maybe checking out the extra NAS features that this openWRT has to offer.

When I hold the reset and power on, I can get it to a state where the power and ethernet flashes alternating green (back and forth). What does "nmrp" mean?

NMRP is a protocol spoken by U-Boot on Netgear routers. Ethernet
code 0x0912. It allows a router to be told to download and run a new
firmware image.

You can't run pihole on the router, it's to resource heavy, and there's
no port. But there's an adblock package doing pretty much the same.

1 Like

As of this writing, I can only communicate with the router by holding the reset button while powering up.
I don't know anything about NMRP. I'll look into it. Any guidance would be appreciated.

there was guidance earlier in this thread - nmrpflash

Link to a tutorial already provided in my previous post.