Unbricking Archer C6U v1.0 (EU) - UART only reads garbage

Hey guys.

I bricked my router.
The same router seems to be covered here and in a few other threads but I haven't seen anyone with this particular issue.

Due to my own actions I seem to have bricked my router (messed a bit too much with the firmware) and it is now boot looping. The green power led turns on for about 10 seconds, turns off for a second. Then all leds turn green, then one turns orange. And then it's just the one green power led again.

I haven't tried TFTP yet, but I have been trying to use a flipper zero as a UART - USB bridge but I've only been able to read garbage. Each boot I read about 2000 bytes of nonhuman-readable bytes.

The flipper recognizes the baud rate as being 9600. Any input I send does not get echo'd back. If I short the RX and TX pins I can echo to myself.

Does anyone know what's going on here?

More than likely the speed is 115200 (8-N-1) at the point where it becomes unreadable. Try that and report back.

You're right I just realized where I messed up. Flipper zero is taking the baud rate from my host, which is using screen configured with 9600.

I now tried using minicom with those exact settings, and I am seeing some repeated patterns. But it's still not readable. I'll keep missing with the settings and other serial consoles for a bit.

Also no luck using picocom. And puTTY is also reading the same.

I do clearly notices it's the same data every instance of the boot loop. So I guess it's just a matter of guessing the correct settings then?

It could of course be related to the flipper zero (though it would be weird), so I'll try to get my hands on a regular UART-USB adapter tomorrow.

I am an idiot and I hadn't connected GND, when I did it started working.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.