Unbrick TP Link Archer C20

Hi All,

hope you guys could help me out on unbricking TP Link Archer C20 v1
I installed OpenWRT from https://openwrt.org/toh/tp-link/tp-link_archer_c20_v1, however something went wrong.
Currently when i turn it on - only USB LED lights up and nothing else, USB LED shines for a couple of seconds and turns off.
So i bought CP2102 chip to connect to the router via serial, however was not receiving anything in Putty console - decided to check the voltages on the TX and RX pins and they are both 0. Do i need to do any additional steps to be able to connect to the router via serial?

Thanks

for the COM port to work, you need to unsolder the jumpers R600 and R601

Murchic, thanks for the reply,
do you mean solder these pins together?
20181112_190905

if there is still no response in the serial - does it mean bootloader is erased?

you need make jumper instead r600 and r601, use solder

From here its difficult to see if you have damaged the board, but it looks like you cut 3 or 4 tracks.

Grab some alcohol and clean up the board, then post another picture.

Hello @bss007, I was wondering if you managed to revive your router. Unfortunately I find myself in the same predicament; not even TFTP is working. Some information online leads me to conclude the bootloader may have been overwritten, so I'm wondering whether I should pay somebody to enable the serial port or buy a SOIC8 clip and flash the ROM.

Have you managed to find a solution? I flashed the wrong image and got a non funciotional device. USB led turns on for about two seconds and then turns off. Serial port is non functional. Not sure if soldering/unsoldering is needed. @Murchic and @root, could you be more specific? I got a SOIC8 clip and wrote a c20v1 flash dump (EU version) I got somewhere here on this forum. However, nothing changed.

I bought a SOIC8 clip and used my Raspberry PI to recover my router using, if I recall correctly, the instructions under Recovering from a bad flash / Unbrick your router: https://pwassi.privatedns.org/lede/archerc20i/.

Hi, no, i gave up and thrown the router into a drawer. But i see you have found a solution so might as well give this a try