Unbrick TL-WR1043ND v4

I've got a tplink TL-WR1043ND on which I tried to upload openwrt. The install partly worked. It changed ip address to and I see ports 22 and 53 open. I managed to ssh onto the router using root (no password).

My question is how do I enable http access ? or if needed, reload openwrt ?

You probably uploaded a snapshot, rather than a release build - only the later has luci (the webinterface) preinstalled. You can now install luci at runtime (check the wiki) or sysupgrade to a 19.07.x release build over ssh.

It's a snapshot: OpenWrt SNAPSHOT, r15169-36e0268aa6
The basic question is how to load anything ?
Do I get the sysgrade binary and push it using a tftp server on

No, your device isn't bricked at all - just the webinterface isn't preinstalled, but you have full access via ssh and can use those facilities to install the stable release (or install luci via opkg). For details, please do look into the wiki.

Please forget about tftp or recovery, you don't need that here - and trying those have a larger risk of really bricking fomething.

1 Like

Actual solution
1 ) change router ip address to avoid conflict with ISP controlled internet gateway.
2 ) wget sysupgrade.bin file
3 ) sysupgrade -v /tmp/sysupgrade.bin

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.