Unbrick RT-N56U leads to other questions

Hi there,

I've been using several Asus RT-N56U for testing/labs. A few days ago, while trying to improve some networks stuffs I tried to create a vlan with it's own DHCP range. For an unknown (yet) reason, it failed and I was still getting IP address in the initial range despite excluding the said vlan interface from this DHCP.

Thinking things might have been improved from 19.07.08, I decide to upgrade to 21. Without re-reading the docs... Can you see it coming? I did the upgrade using LUCI, and ... KABOOM. Bricked router. Funny thing is, in the rush, trying to get things back, I took my backup router and decided to plug the USB (my extroot, disconnected of course while doing the upgrade). Since the router was still in 19.07.7, I made an update to 19.07.8... Using luci... yeap. At this point, only the power led works (fix by default, blinking in recovery mode).

After trying the usual stuffs to revive these poor things (tftp,asus recovery tools), I was still not able to make them work again until I did an Asus Recovery using a build for "AC51 Full" from padavan. My guess is this build as some boot files other firmware didn't have.

The problem is, the router identifies itself as both an RT-N56 in some part of the webgui, and as a AC51 in some others, including the firmware update page. So, while trying from there to upgrade using any RT-N56U firmware, the router rejects the file and ask for a AC-51 build. Using tftp from here didn't work neither and gets me back to the point where I have to use recovery tool with pavadan AC51 firmware...

thus, two questions:

  • Is there any way to force the update to a RT-N56 Firmware.
  • Since I have a third still working RT-N56, can i create a full (really full, with all boot related files) from this one to inject into the two others?

Thank you for reading this long post =)

I just noticed that Luci made possible to backup different parts of the system. I'll try to dump them all and recreate a valid firmware from that. Has Anyone experienced this before?