Unbrick Fritzbox3990


I set the LAN interface under Network=>interfaces to a configured wireguard device. Now i cannot contact the Router anymore.
I haven't setup the wifi yet.
Before installing OpenWrt it had the FTP bootlader with adam2, now i cannont contact it.
Any Idea on how to get a connection?
I tried its old IP and standard
So yeah, HELP?

The image shows where i did my whoppsie, but different hardware (the one from pic still works).

reset it ?


I am in failsafe mode i think. I have a rapidly blinking LED and it's red.
I have connecet to LAN1 and 3 (not where DSL is supposed to go).
I disconnected the cable in the same boot and i have changed cables.
I have manually assigned my dev machines device ip to
ip addr add dev eth0
I can't ping the router :frowning: .

You are doing a lot of things I do not understand:
Set your computer to
Subnet mask
plug one ethernet cord in port 2 and one in computer(just in case 1 is being used for some reason).
Power on the router.

According to below this will start some flashing and then rapid flashing. During the rapid flashing press the reset button.
There are three different (power) LED blinking speeds during boot for most of the routers:

  • A power-on sequence of lights that is specific to the device's bootloader

  • Then a fast 5-per-second blinking rhythm during two seconds, while router waits for user to trigger the failsafe mode, typically by a button press

  • Then either

    • A faster, 10-per-second blink if the user pressed a button and failsafe mode was triggered

    • A slower, 2.5-per-second blink continuing to the end of boot, if the failsafe was not triggered and the normal boot continues

If you get the 10-per-second blink try in a browser.

Come back if that fails.

i have a continuos fast flashing. NO break in between.
Here is the video.

I cant ping router With ip on dev machine
ip addr add dev eth0 or
ifconfig eth0 netmask 255.2555.255.0
I am in LAN2.

Okay, give up on whatever you are trying to do. That is 10 flashes a second it is in recovery mode.

Plug directly into the router with one cord going to any computer with a static address set to and a subnet of Do not have anything plugged into the wan port.

It is in recovery mode now, so leave it powered on and, from a browser put in the address bar hit enter and reply the results.

Sorry, I keep using recovery when it is in fact in failsafe mode.

This is the plug is.
The result is i cant reach network

# ping
From icmp_seq=NUMBER Destination Host Unreachable

So i dont need to try the browser

Manual command for manual assignment was either:
ip addr add dev eth0 or
ifconfig eth0 netmask 255.2555.255.0
neither workered.

Try port 1.

Port 1,2,3 give the same result => Destination Host unreachabe

You got that from a browser?

[quote="welap, post:9, topic:191396"]
Destination Host unreachable

My manual assignment mus be wrong

If the message is simply "Destination Host Unreachable," then there is no route from the local system, and the packets to be sent were never put on the wire.

You do see the error in that subnet mask. That was not copied was it?

No that was not copied, but fatfingered. I am using a different device for communication.

I do not know what to tell you:

Many people come here and the community makes suggestions and get replies like "that won't work because xy and z"; dismissed before even tried.

So, according to the blinks it is in failsafe mode.

You not trying to get in using a browser is arguing with the router.

If the Host is Unreachabe the host is unreachable.
figuratively speaking, i am on a bicycle and saying "i cant use the road because there is no road"
and you are saying:
"what if you use a car". That doesn't magically make a road appear.

When i am in fail save mode next step is fixing your settings either using ssh or serial. But ssh is doest't work because there is no route to host, so i pinged it. I probably pushed garbage into the peripherals and now the peripherals are fucked, but what i don't understand why the recovery image pushed my garbage in the peripherals during initialisation, or why it didn't properly reinitialize them during boot, cuz thats the point of the image.

So thanks for the help, but i think my next step is the soldering iron.

ssh root@
ssh: connect to host port 22: No route to host
1 Like

Solution was using manufacturer recovery tool:
recover router => reinstall openwrt on router


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.