Unable to setup Google Home devices

Recently switched to OpenWrt and since then have been unable to setup any Google Home devices. It's as if they are unable to register themselves on the network and complete their setup.

I have a PiHole setup but even with that disabled, they aren't able to login to the network. Have tried with WPA2/3 and combinations of both.

Is there any trick or known issue with these?

I've got several, running (intentionally) over 2.4Ghz wifi, without any issues.

Do you mind sharing your wireless settings? even on an Open network I am unable to finish setup

Do you have fast transition (802.11r) on the wifi that you’re trying to connect the Google Home devices? I’ve encountered issues with IoT devices not wanting to connect to my wifi before. Took me a few days to figure it out, but once I turned off fast transition, my devices were able to connect without a hitch. May be worth a shot to try out if you do have fast transition turned on.

I can post it, once I get home.

I am, however, runnig 19.07 on my APs, and have 802.11r enabled.

When I was using 21.02 I didn’t have an issue with it. But after going to 22.03, that’s when 802.11r became an issue for my Ring Security devices. Weird… to say the least. I figured since my IoT devices never move around anyway, it’s no big deal to have FT off.

802.11r is disabled, and is only an option on the secured networks so my "open" test network definitely doesn't have it on

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'SE'
        option legacy_rates '0'
        option channel '40'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option country 'SE'
        option legacy_rates '0'
        option htmode 'HT40'
        option channel '9'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid '24'
        option encryption 'psk2'
        option wps_pushbutton '0'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option key 'asdfghjkl'
        option mobility_domain 'd987'
        option nasid '111111111111'
        option network 'lan'

config wifi-iface 'wifinet1'
        option ssid '5'
        option encryption 'psk2'
        option device 'radio0'
        option ieee80211r '1'
        option ft_over_ds '1'
        option key 'asdfghjkl'
        option network 'lan'
        option mode 'ap'
        option ft_psk_generate_local '1'
        option mobility_domain 'c331'
        option nasid '11111111111'

Can you post your own settings? Hopefully we can spot the error(s) in the config that are causing your issue. I think that's better than trying to implement someone else's config.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2e:565b:7ea2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        option broadcast '10.0.0.1'
        list dns '10.0.0.2'
        list ipaddr '10.0.0.1/24'
        list ipaddr '192.168.1.1'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username 'xxxxxxx@broadband.vodafone.co.uk'
        option password 'xxxxxxx'
        option ipv6 '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Home-Network-5GHz'
        option key 'xxxxxxx'
        option encryption 'psk2'
        option time_advertisement '2'
        option ieee80211w '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option band '2g'
        option cell_density '0'
        option htmode 'HT40'
        option channel 'auto'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Home-Network'
        option key 'xxxxxxx'
        option encryption 'psk2'

/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'
        option enable_tftp '1'
        list server '10.0.0.2'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option netmask '255.255.255.0'
        list dhcp_option '6, 10.0.0.2'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'server'
        option dns '1'
        option mac '18:C0:4D:A4:11:80'
        option ip '10.0.0.2'

/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'emby'
        option src 'wan'
        option src_dport '8096'
        option dest_port '8096'
        option dest_ip '10.0.0.2'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'homer1'
        option src 'wan'
        option src_dport '8080'
        option dest_ip '10.0.0.2'
        option dest_port '8080'

The lan definition has multiple errors...

Broadcast is wrong. You can actually simply omit this and it will happen automatically, but if you're going to include it, it must be correct. The broadcast address is always the top of the network range. in this case, it appears you have defined 10.0.0.1/24 as the lan address (more about this later), so that means broadcast is 10.0.0.255.

Why do you have another lan address specified (192.168.1.1) -- this is invalid due to the fact that you already have an address using a different subnet, and it also would be invalid on its own because you haven't specified the network size (such as /24) or the subnet mask (which is another way of doing the same thing).

Finally, you've specified a different DNS here... this doesn't actually have the effect you probably expect when defined in the lan interface.

So... start by removing these items:

I would highly recommend turning off 802.11w (at least for now). Not all devices work properly when this is enabled.

Remove the netmask from the DHCP server's lan definition.

Then restart your router and try again.

1 Like

Thank you so much!

As I said, this is my first time delving into OpenWrt and those were just side effects of me trying things to get it setup. I ain't sure what option did it exactly, but it all "popped back to life" and was able to connect, and setup on the others were successful.

Since making these changes, my custom DNS is no longer having requests forwarded to it, what would be the correct way to add it back in? 10.0.0.2

Merry Christmas!

list dhcp_option '6, 10.0.0.2' is the right way, assuming your clients pick it up.

Try removing the extra space after the comma.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.