Unable to restore stock ROM in TP-Link CPE210 HW 1.1 after flashing LEDE


Has anybody tried to restore stock ROM in CPE210 hardware version 1.1. after flashing LEDE? I have reviewed TP-Link´s forum and it seems it is not possible. People has tried the Pharos OS TFTP recovery (http://forum.tp-link.com/showthread.php?81684-How-to-use-firmware-recovery-function-of-Pharos-CPE) as well as from the OpenWRT/LEDE web GUI, and both fail.

Everybody labels flashing to OpenWRT or LEDE as "one-way" action because thet suspect that OpenWRT/LEDE "changes something" in the flash, so it breaks any restore to stock ROM . Bellow I list them:

  1. OpenWRT/LEDE misses partitions of the stockROM partitions. Bellow is the partition table with stock ROM:

U-Boot partition
partition fs-uboot base 0x00000 size 0x20000
partition partition-table base 0x20000 size 0x02000

Firmware partitions
fwup-ptn partition-table base 0x00800 size 0x00800
fwup-ptn os-image base 0x01000 size 0xcbf29
fwup-ptn soft-version base 0xccf29 size 0x00015
fwup-ptn support-list base 0xccf3e size 0x0063c
fwup-ptn file-system base 0xcd57a size 0x3e4001

  1. OpenWRT/LEDE changes something in the environment of the SafeLoader, which breaks the standard recovery mode.

Can anybody check it and (if feasible), patch LEDE to solve it?


Please, file a bug here: https://bugs.lede-project.org

Bug filed for followup: https://bugs.lede-project.org/index.php?do=details&task_id=902

Have the same problem and find the same problem with CPE510 HW 1.1.
I expand the report allready.
Can some one confirm problems on CPE510 HW 1.1 or have I open a new thread?

helloo i have a CPE220 v.1 my problem is how to restore stock firmware.. From LEDE to stock any one can help me pls....

Follow these steps from the OpenWrt wiki. Your router doesn't have to be bricked to use this approach...


To get a TFTP server (if you don't already have one)...

10 Best Free TFTP Servers (Windows, Linux, Mac) -

Is there any solution for this issue?

I have 2 units CPE210 v1.1 which works with the LEDE firmware 1.7 and 1.8, but unfortunately I can't revert back to original firmware.

Tftpd detects the unit but the progress will never finished 100% it's stuck between 60-80%.

I've tried to go back to openwrt 1.5 chaos but it also didn't work through gui or tftpd recovery and the log is identical.

bumping? I don't know if that is allowed, it's been 2 years

I had a old build. But i was able to revert to original firmware with tftpd64. It didn't require a switch, but i did plug it into the LAN1 port of the unit, rather than the poe injector. Used a Thinkpad with a intel nic, windows 8, and set my IP to desired, and BINDed thje address in TFTPd64 (can do it in the options, i presume to make it less prone to guess the interface) to, and let the unit have power for several minutes (to program and reboot) and sure enough pharos booted back to original firmware. Have to rename the firmware recovery.bin.

so i can confirm the instructions here: https://oldwiki.archive.openwrt.org/toh/tp-link/tl-cpe210#debricking are legit

New URL: https://openwrt.org/toh/tp-link/cpe210#debrickingrestore_stock_firmware_webrevert

The old page is for archival purposes only and does not receive updates any more.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.