Unable to resolve dns on Vodafone Greece

I have thw following config at /etc/config/network:

nterface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'


config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip4table '1'
        option 'dns' '192.168.1.1'

config globals 'globals'
	option ula_prefix 'fdd2:a40d:d919::/48'

# WAN

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '00:20:da:86:23:75'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option tone 'auto'
	option firmware '/lib/firmware/vr9-B-dsl.bin' 

config interface 'wan'
	option device 'dsl0.835'
	option proto 'pppoe'
	option username 'guest@adsl.gr'
	option password '******'
	option ipv6 'none'
	option keepalive '10'
	option mtu '1492'
	option dns '8.8.8.8, 8.8.4.4'
	option peerdns '0'

config interface 'voip'
	option device 'dsl0.837'
	option proto 'dhcp'
	option defaultroute '0'
	option ip4table '2'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

And I try to resolve google.com but I fail to:

ping www.google.com
ping: bad address 'www.google.com'

The ping is performed on the router itself. The version of openwrt is:

NAME="OpenWrt"
VERSION="SNAPSHOT"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt SNAPSHOT"
VERSION_ID="snapshot"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r20450-90f55f5bf1"
OPENWRT_BOARD="lantiq/xrx200"
OPENWRT_ARCH="mips_24kc"
OPENWRT_TAINTS=""
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="OpenWrt SNAPSHOT r20450-90f55f5bf1"

I can ping though ip addresses:

ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=60 time=18.036 ms
64 bytes from 1.1.1.1: seq=1 ttl=60 time=17.860 ms
64 bytes from 1.1.1.1: seq=2 ttl=60 time=17.862 ms
^C
--- 1.1.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 17.860/17.919/18.036 ms
ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=115 time=18.066 ms
64 bytes from 8.8.8.8: seq=1 ttl=115 time=17.906 ms
64 bytes from 8.8.8.8: seq=2 ttl=115 time=18.547 ms
64 bytes from 8.8.8.8: seq=3 ttl=115 time=17.768 ms
^C64 bytes from 8.8.8.8: seq=4 ttl=115 time=18.003 ms
^C
--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 17.768/18.058/18.547 ms

The /etc/resolv.conf is:

search lan
nameserver 127.0.0.1
nameserver ::1

Not sure there's supposed to be a , between the IPs of the wan dns, try removing one of them.

1 Like

I did that I managed to completely remove it:

nterface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'


config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip4table '1'
        option 'dns' '192.168.1.1'

config globals 'globals'
	option ula_prefix 'fdd2:a40d:d919::/48'

# WAN

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '00:20:da:86:23:75'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option tone 'auto'
	option firmware '/lib/firmware/vr9-B-dsl.bin' 

config interface 'wan'
	option device 'dsl0.835'
	option proto 'pppoe'
	option username 'guest@adsl.gr'
	option password '******'
	option ipv6 'none'
	option keepalive '10'
	option mtu '1492'
        option peerdns '0'

config interface 'voip'
	option device 'dsl0.837'
	option proto 'dhcp'
	option defaultroute '0'

Still the same. If I change the /etc/resolv.conf as:

nameserver 8.8.8.8

works fine. Is there a way to permanently change the /etc/resolv.conf ?

uci delete network.lan.dns
uci delete network.wan.dns
uci add_list network.wan.dns='8.8.8.8'
uci add_list network.wan.dns='8.8.4.4'
uci commit network
/etc/init.d/network restart
# uci delete network.lan.dns
uci: Parse error (invalid command) at line 1, byte 0

uci del maybe?

Worked had an error thew /etc/network I fixed the first line as:

config interface 'loopback'

The run the commands:

uci add_list network.wan.dns='8.8.8.8'
uci add_list network.wan.dns='8.8.4.4'
uci commit network
/etc/init.d/network restart

And worked like a charm.

Most likely this snapshot was not the finest commit.
Remove the line with dns from lan and add

        list dns '8.8.8.8'
        list dns '8.8.4.4'

under wan.