Unable to recognize device USBS

I'm creating a custom build for my ZBT WE826, but in /dev it won't appear the USBSX, I've tried reading some guides from the OpenWRT wiki and other sites about a possible missing usb module, I've installed all the packages in those guides for usb, but still no luck. I need it to be recognized so I can use a SIM card with my ZBT for 4G. Anyone have an idea of a package I might be missing?
Some of the packages I've tried:
usb-modeswitch, kmod-mii, kmod-usb-net, kmod-usb-wdm, kmod-usb-net-qmi-wwan, uqmi

and the ones from this guide:


Did you see it when pluging it and running dmesg?

try searching for "ZBT WE-826 openwrt" too. I think that the chipset is mt7620.

kmod-usb-storage kmod-usb-storage-extras have you tried either of those?and the file format kmod-fs-ext4 kmod-fs-ext3 etc...or is this just some kind of wifi or bluetooth usb?

Its a ZBT WE826

I have compiled the system from scratch, selecting all modules and packages one by one, but my modem won't recognize in /dev my SIM card, for what I know it's detected as ttyUSB0 or 1, but it doesn't show up at the /dev. I've tried the approach from this tutorial:

but no luck, I've tried all the usb modules to compile but also no luck, I'll tryout the packages you listed and see if anything is missing, thx

Yep its exactly that chipset, but im compiling the kernel from scratch and now I'm looking for any usb module/package that i might have missed, I need my ZBT to recognize the SIM card but it only shows in /dev the cdc-wdm0 device and the serial device ttyS0 and ttyS1, tomorrow I'll post the output of my dmesg | grep USB command.

Why you need to recompile all, it is easier to build your own image with precompiled packages instead.

That's exactly what I'm doing, from scratch I mean, using the source code with zero packages selected and choosing one by one, because I need to save the maximum amount of space that I can

just remove the common ones for ipv6, luci, etc...

In OpenWRT I used:

opkg list-installed | awk '{print $1}' | sed ':M;N;$!bM;s#\n# #g'

to get a list of packages in that way you could see which ones you can remove

Sample for extroot I used on OpenWRT:

make image PROFILE=XXXXXXXX FILES=files/ PACKAGES="kmod-usb-storage block-mount kmod-fs-ext4 -dnsmasq -firewall -kmod-crypto-aes -kmod-crypto-arc4 -kmod-crypto-core -kmod-ipv6 -libiwinfo-lua -liblua -libubus-lua -libuci-lua -lua -luci -luci-app-firewall -luci-base -luci-lib-ip -luci-lib-nixio -luci-mod-admin-full -luci-proto-ipv6 -luci-proto-ppp -luci-theme-bootstrap -rpcd -uhttpd -uhttpd-mod-ubus"

This are my notes about: https://gist.github.com/braian87b/4a9048dcc2e2fd244f7d44b8896b7ccc

@Baratao00 Post your dmesg output.

So surprisingly my 4g internet worked through the SIM card, I don't understand very well yet, but now the device node I need to focus on it's the cdc-wdmX and not the ttyUSBX anymore, everything seens ok, thanks for your attention and sorry for my noobish doubts xD