Unable to make Openwrt 21.02.1 work on Asus RT-AC65P


I have spent the last 10 hours trying to make Openwrt work on a Asus ACRT-65P router, but no matter which installation method I choose (ssh, recovery) and no matter which build I try (factory, snapshot) after the flashing is complete the router seemingly gets into somekind of a cycle where the ethernet cable just keeps disconnecting and reconnecting and I cannot reach the CLI via SSH nor Luci over the web (factory), or ping the router on The WAN cable is connected to a modem from the ISP, and the computer used for the configuration is connected to one of the ethernet ports (3) on the back of the router. The static IP addresses I used during the installation attemps were and - but it does not make any difference which one I try. I have no idea what I am doing wrong :confused:

Do you guys have any idea what should I try?


1 Like

Thank you, but this is exactly what I have done. The wiki page contains these instructions too: https://openwrt.org/toh/asus/rt-ac85p

The only difference is that I used the filename as is (i.e. with the version number included) in the commands

try using an image from an older release, then (sys)upgrade your way forward.

Could you tell me where do I find the list of old images?

Moreover, do you think it matters that I installed the latest Asus firmware before starting any of this? Does the openwrt firmware rely on the Asus firmware in any way?


then drill down into .../[version]/targets/ramips/mt7621/

if the new ASUS FW included a more recent uboot, there might be changes.
you could also try the TFTP installation, instead of SSH.

Thank you for the suggestions, I will try to reinstall the first firmware available on the Asus website. If that does not solve the issue, I will try an earlier Openwrt release. I find it odd that factory reset does not seem to reset the Asus firmware version, only the settings.

they never do, most routers don't have a backup fw stored, which means if it'd reset it the way you wanted it to, it'd wipe the firmware, resulting in a soft bricked the device, requiring recovery.

Just a quick, update: reinstalling the "factory" Asus firmware did nothing. I am facing the same issue after installing openwrt 21.02.1 ... I will try an older openwrt release as suggested after the firmware restoration is done.

I tried 21.02.0 and 21.02.0-rc1, but it still does not work. It looks like the router keeps restarting, which explains why the Ethernet interface in Windows's Network Connection keeps cycling between "Network cable unplugged" and "Unidentified network"... I have even moved the Ethernet cable to the leftmost plug (1), and tried the installation again, but that did not change anything either. Admittedly, this is my first time trying to use Openwrt, but I do everything according to the wiki, yet the router is clearly malfunctioning. Firmware restore works, the router works flawlessly with the Asus firmware, but Openwrt just wont run. What am I doing wrong?

that we don't know, but I'd try the TFTP flashing instead :wink:

I just did (and disabled the firewall beforehand). Same result: router stuck in a reboot cycle.

I used the following command

tftp -i PUT openwrt-ramips-mt7621-asus_rt-ac65p-squashfs-factory.bin
Transfer successful: 9175040 bytes in 3 second(s), 3058346 bytes/s

So basically I have now tried every method (SSH mtd-write, TFTP, Asus recovery) and all of them failed to produce a working router with openwrt...

yeah, bummer :frowning:
the only thing I can think of now, is serial console, to see why it fails ....

Oh, f*cking finally.

Here is the howto (for Windows users) if anyone needs it:

  1. Download and install the Asus Firmware Restoration Tool:

  2. Get the the following "kernel" build from here:

  3. Set the IP address of the network interface being used to connect to the router: /

  4. Power OFF the router for 20 seconds, then power in ON while pressing the RESET button at the same time. Keep pressing it until the power status led starts to blink.

  5. Start the Asus Firmware Restoration Tool (Start > ASUS Utility)

  6. Browse the kernel .bin file that you downloaded, then click Upload.

  7. Wait for the upload and "recovery" to finish, then click Close. After 100% you may receive the message "could not connect to the wireless router", ignore it.

  8. Set the IP address of the network interface being used to connect to the router back to DHCP. You should be able to successfully ping the router at

  9. SSH into the OpenWrt CLI:

ssh root@

See URL below for additional info:

  1. Install Luci (GUI):

opkg update
opkg install luci

See the URL below for additional installation options:

  1. Install the sysupgrade below via the web interface after logging into Luci (System > Backup/Flash Firmware > Flash New Firmware Image)


You are done.

Thank you kind Russians who suggested the solution here :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.