Unable to make 5GHz wifi work on NETGEAR RBR40

Recently I am working on making OpenWrt to work with (NETGEAR RBR40)[https://openwrt.org/toh/hwdata/netgear/netgear_rbr40] and RBS40, a set of routers NETGEAR produced as 'MESH' networking, with IPQ4019 processor, 512M RAM and 4G eMMC flash.

I am building firmware from the latest development snapshots and enabled several modules like LuCI to make configuration easier. I flash the firmware with the nmrpflash program and the router works as expected, except the 802.11ac wifi (11n works, though). The git log of the commit 2cb24b3f3c showed everything works correctly with RBR50, so I think there could be

I am still a newbie with OpenWrt and I found the config file /etc/config/wireless of OpenWrt greatly differs from the stocking firmware, and the MAC address of radios are not correct. I don't know if this could be related with the issue.

Here are my system logs and config files:
ubus call system board:

root@OpenWrt:~# ubus call system board
{
	"kernel": "6.6.74",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 5 (v7l)",
	"model": "NETGEAR RBR40",
	"board_name": "netgear,rbr40",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "SNAPSHOT",
		"firmware_url": "https://downloads.openwrt.org/",
		"revision": "r28739-69890e16b3",
		"target": "ipq40xx/generic",
		"description": "OpenWrt SNAPSHOT r28739-69890e16b3",
		"builddate": "1738386419"
	}
}

cat /etc/config/network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf8:17a2:3ec6::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan6'
	option device 'wan'
	option proto 'pppoe'
	option username '<REDACTED>'
	option password '<REDACTED>'
	option ipv6 'auto'

cat /etc/config/wireless

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option channel '1'
	option htmode 'HT20'
	option txpower '30'
	option country 'AU'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '<REDACTED>'
	option encryption 'psk2'
	option key '<REDACTED>'
	option wps_pushbutton '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option channel '36'
	option htmode 'VHT80'
	option txpower '23'
	option country 'AU'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<REDACTED>'
	option encryption 'psk2'
	option key '<REDACTED>'
	option wps_pushbutton '1'

System Log: see [https://pastebin.com/3PbtECkJ]

Hope this will help finding the issue.

I'm having the same issue with the release version of 24.10.0. I've tried enabling/disabling wds, changing channels (36, 40, 48, and 60), and a custom build with non-ct drivers, nothing seems to make a real difference. If I get my cell phone close, the 5ghz ssid will sometimes show up, but won't connect, usually it will say that I have the wrong password. The RBS40 doesn't show it in a scan, but it does show the 5ghz network from my asus router.

Same here with the 24.10.0 release: 2.4Ghz is working, but both 5Ghz Interfaces are super weak / not usable (client sees them only within ~10cm from the rbr40).
I tried more or less the same as @ozzie286 (additionally checked different country settings for WiFi) - no dice.

Did anybody even get the rbr40 5Ghz WiFi working properly in the past i.e. with an older Openwrt version?

Also, the commit which introduced support for the rbr40 says the device is identical to the rbr60 except for the antennas, and basically seems to enable the rbr60 modifications also for the rbr40. Maybe as a step forward: is there a way to check at runtime if the extracted calibration data for the ath10k is valid?

1 Like