Unable to login to SSH

I'm using latest OpenWRT on NEXX WT3020F and tried Windows 10 build-in OpenSSH client and recommended on OpenWRT Wiki Cmder Full package and in both I get:

Unable to negotiate with port 22: no matching host key type found. Their offer: ssh-rsa

when try to log into SSH.

What is going on?

WIth OpenWRT the IP address is

Writing from breed-mt7620-reset1.bin to mtd0 … [w]
Flash firmware
Use the factory.bin image for initial install via stock firmware web-UI.

  1. Download firmware (see above)

  2. Connect to the WLAN "NEXX_…", no password is needed or connect via LAN cable (preferred)

  3. Go to → Username: admin, Password: admin, System Setting → Upgrade Firmware

  4. Select the downloaded firmware file and press "Upgrade"

  5. After a while, you will get "Rebooting… System reboot takes a few moment, you might need to reconnect to the Router after rebooting."

  6. After the system comes up, you should be able to log-in via LuCI at

I changed address to 8.1 via web interface to avoid interference with my other subnet. And router is reachable by So this is not the cause.

There is problem with logging to SSH. And seems to be problem with something like "ssh-rsa".

i have installed OpenSSH official for Windows 10 and i can connect

C:\Windows\system32>ssh  **-l root**
The authenticity of host ' (' can't be established.
RSA key fingerprint is SHA256:LXFZuMk+mVCbImztoUVx9bwbqlB5EthGx7k9JkZw4TQ.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '' (RSA) to the list of known hosts.
root@'s password:

BusyBox v1.29.2 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r7986-dc9388ac55


I use also Putty without problems

Are you sure you want to continue connecting (yes/no)?

ssh sees the new IP as an unkown host, if you trust that you are connected to ypur router then just type yes and continue.

The list of know hosts is in a text file

=== alternative to -l option is use this ===
> ssh root@

no go.


I will try putty.

Seems to be a problem with the Windows client: https://www.google.com/search?q="unable+to+negotiate"+"their+offer%3A+ssh-rsa"

Try to regenerate dropbear host key:

rm -f /etc/dropbear/*
service dropbear restart

Result should be like this:

# ls -l /etc/dropbear/dropbear_rsa_host_key
-rw-------    1 root     root           805 Sep 23 23:21 /etc/dropbear/dropbear_rsa_host_key

# dropbearkey -y -f /etc/dropbear/dropbear_rsa_host_key
Public key portion is:
ssh-rsa <...> root@OpenWrt
Fingerprint: sha1!! <...>

Also try this:

ssh -oHostKeyAlgorithms=+ssh-rsa root@
1 Like