Unable to Install Packages, wrong kernel version?

I'm a LEDE noob, having just installed it on my BT Home Hub 5a. It was a struggle getting this far (the initial build I installed wouldn't route between Lan and Wan, I wasted days trouble shooting, gave up and reflashed with that days build, worked out of the box :slight_smile:).

LEDE Reboot SNAPSHOT r3202-37b489f / LuCI Master (git-17.030.34151-7c74430)

Now it is all set up and working nicely on my home network. I'm trying to setup USB support so I can plug a thumb drive in to my router to store vnstat log files, but I cannot seem to get that to work. Following the LEDE guide for Storage (https://lede-project.org/docs/user-guide/drives), I'm struggling to find out which host controller I have and when I try to install kmod-usb2 (guessing this would be the correct one), I get the following

opkg install kmod-usb2
Installing kmod-usb2 (4.4.46-1) to root...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb2:
  •  kernel (= 4.4.46-1-524d73b0a8c5db36e7813c8f61ee6672) *
  • opkg_install_cmd: Cannot install package kmod-usb2.

This seems to be suggesting that it requires kernel 4.4.46, I currently have 4.4.45 and the kernel version list on the Lede-project site suggests that no devices have 4.4.46, so why are the packages expecting this?

I know this is a similar issue to (Kernel version mismatch when install kmod), but I worried that I will be messing things up by forcing the install.

I'm getting the same error when trying to install OpenVPN

opkg install openvpn-openssl
Installing openvpn-openssl (2.4.0-3) to root...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
  •  kernel (= 4.4.46-1-524d73b0a8c5db36e7813c8f61ee6672) *
  • opkg_install_cmd: Cannot install package openvpn-openssl.

I've installed openvpn-easyrsa, but cannot install openvpn? I have done a package list update before trying all these things.

Given I'm getting the same errors for many packages, I'm suspecting that I must be doing something wrong, but cannot figure out what.

On the download page for the firmware (downloads.lede-project.org/snapshots/targets/lantiq/xrx200/) it does not seem to list the revision or kernel version next to each, where could I find this, I'm struggling to find change logs.

Any help would be gratefully received.

Thanks in advance.

The problem is that you are dealing with a moving target. Because LEDE has not
yet made a release, it's the only target available right now.

But the result is that the repository is being recompiled with new versions of
things at least once a day.

So when you go back a few days later to install something new, it may involve
newer versions of packages.

You need to either build things yourself, or install everything at once (which
in you case means downloading a new image for your device and flashing it again,
then installing the packages that you want.

In the long term, it really is worthwhile to setup your own build environment.

David Lang

1 Like

Contrary to the snapshot builds, 17.01-rc1 is not a moving target (it will be obsoleted by -rc2 soon'ish, but it's frozen and can be used for installing further packages later on).

Ok, thanks. That makes sense.

I think I shall try to force the install of the packages I want using the --force-depends option, and if breaks things, I'll flash the latest shapshot after backing up my current settings.

Just one final question before I re-flash my router, which in all respects is working perfectly apart from the OpenVPN. Actually, as far as I can tell the openvpn package is working (the daemon is running). The issue is that I seem unable to create the tun0 interface.

I've added the following to my /etc/config/network file and tun0 appears in Luci. However, if I run ifconfig, tun0 does not appear in the list of interfaces? I've restarted network, and rebooted the router, makes no difference!

config interface 'vpn0'
option ifname 'tun0'
option proto 'none'

On the download page, https://downloads.lede-project.org/snapshots/targets/lantiq/xrx200/, the top sub directory is called packages. Does this contain all the packages which are compatible with the current download version of the firmware? If so, it does not contain a package with openvpn in the name, implying that there is no openvpn package available yet.

Is that correct?

1 Like

No. That contains only the target specific packages.
Most packages are in snapshots/packages/yourprocessorfamiily
Check the device wiki page or /etc/opkg/distfeeds.conf for the correct link

Ok, thank. That could explain why so many packages seem to be not working. According to https://wiki.openwrt.org/toh/bt/homehub_v5a my router has a MIPS 34Kc processor, and that is not listed in the Index of /snapshots/packages/ there is a MIPS 24Kc, but not a 34.

Perhaps my router is not fully supported :frowning:

The packages are based on processor architecture and the same packages are used in some cases for several slightly different processor subtypes, like mips_24kc and mips_34kc both use mips_24kc packages.

In the LEDE wiki, your device is listed to use mips_24kc packages.

So, the snapshot packages can be found from https://downloads.lede-project.org/snapshots/packages/mips_24kc/

You could have found that from your router's /etc/opkg/distfeeds,conf file, like I said earlier. This is the list from a similar device. You see that there is the "targets" repo plus several "packages/mipos_24kc" repos listed :

cat /etc/opkg/distfeeds.conf
src/gz reboot_core http://downloads.lede-project.org/snapshots/targets/ar71xx/generic/packages
src/gz reboot_base http://downloads.lede-project.org/snapshots/packages/mips_24kc/base
src/gz reboot_luci http://downloads.lede-project.org/snapshots/packages/mips_24kc/luci
src/gz reboot_packages http://downloads.lede-project.org/snapshots/packages/mips_24kc/packages
src/gz reboot_routing http://downloads.lede-project.org/snapshots/packages/mips_24kc/routing
src/gz reboot_telephony http://downloads.lede-project.org/snapshots/packages/mips_24kc/telephony