Unable to install OpenWrt in Linksys E8450

I bought a new Linksys E8450 (AX3200 Gigabit WiFi Router) which is with the version Firmware Version:1.2.00.
I am trying to install OpenWRT 22.03 with the images
(openwrt-22.03.3-mediatek-mt7622-linksys_e8450-initramfs-kernel or
openwrt-22.03.3-mediatek-mt7622-linksys_e8450-squashfs-sysupgrade) but the GUI shows
"Image file is incorrect". I also tried to downgrade the Linksys firmware version from 1.2 to 1.1 (FW_E8450_1.0.01.101415_prod) but that also fails. Any help will be appreciated on how to install openwrt in this router

Are you using Daniel's instructions?


Hi, Thanks. Yes i tried this and that's where i was trying to downgrade the Linksys 1.2 to 1.1 but that also is failing with the same message "Image file is incorrect".

Are you sure you're using the correct image? According to the linked guide it should have 'ubi' as part of the name.


Are the OpenWrt and stock images the signed versions? That's the key to getting something installed when the router was delivered with version 1.2 firmware.

This is the one that should work right out of the box for you:



Thanks that worked to get me to OpenWRT.
However i am getting the below warning
" System running in recovery (initramfs) mode.
No changes to settings will be stored and are lost after rebooting. This mode should only be used to install a firmware upgrade"
Should i do firmware upgrade now? Which firmware it would be? Can you please share the link?

Go here and grab the bottom one. That gets you to the newest released version on an LTS kernel, so you should only need to do updates when there are security bugs and such.


That worked. Thanks a ton!!! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.