Unable to install on Edgerouter 4

Trying o install OpenWRT using TFTP by following steps:

  1. Connect PC to the eth0 port and set static IP
  2. Switch the device to recovery mode (the LEDs start flashing correctly)
  3. Successfully connect TFTP client to the 69 port (
  4. Transfer the firmware file in the binary format

Router receive file and response: "error code 2 firmvare check failed".
Any suggestions what am I doing wrong? I have tried several different images including snapshots - same result.

Which specific images have you tried? I don't own an ER4, but I see that it has a "kernel" (initramfs) image. Typically you need to install that one first. From there, you will have an OpenWrt installation that will boot, but won't be able to maintain any settings across reboots. Using that OpenWrt image, though, will let you use the standard OpenWrt sysupgrade system to flash a normal sysupgrade image. You will see the two images on the firmware selector page:

1 Like

I've already tried kernel image before. I just tried it again (by your link) with no success - "firmware check failed".

Was the instruction you tried in the wiki?

No. I have no console cable.

A serial console is necessary for installation. The TFTP recovery process rejects unsigned firmware, so it can only be used to recover to stock firmware.

1 Like

This device has easy serial connection. The connector is already on the front and you either buy or build a cisco standard rollover console cable.

Thanks, I'll try.